summaryrefslogtreecommitdiffstats
path: root/cypress_test/Makefile.am
diff options
context:
space:
mode:
authorCaolán McNamara <caolan.mcnamara@collabora.com>2024-05-07 10:12:11 +0100
committerCaolán McNamara <caolanm@gmail.com>2024-05-07 15:12:55 +0100
commitb440a86f7357aec9e00ce8807b49dc01ac09c4d7 (patch)
treec4827823bda066d588ec1594443aad2ce75f6132 /cypress_test/Makefile.am
parenttry rm -f coolwsd instead of rm coolwsd (diff)
downloadonline-b440a86f7357aec9e00ce8807b49dc01ac09c4d7.tar.gz
online-b440a86f7357aec9e00ce8807b49dc01ac09c4d7.zip
get coolwsd log on failure
Signed-off-by: Caolán McNamara <caolan.mcnamara@collabora.com> Change-Id: I88545054c4a79dd0152d13699f80e7f1b235d267
Diffstat (limited to 'cypress_test/Makefile.am')
-rw-r--r--cypress_test/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/cypress_test/Makefile.am b/cypress_test/Makefile.am
index e769b9d799..3b54438808 100644
--- a/cypress_test/Makefile.am
+++ b/cypress_test/Makefile.am
@@ -215,7 +215,7 @@ define start_coolwsd_instance
--unattended \
$(if $(findstring php-proxy, $(CYPRESS_INTEGRATION)),--o:net.proxy_prefix=true) \
> $(COOLWSD_OUTPUT) 2>&1 &
- $(V)$(WAIT_ON_BINARY) http://localhost:$(FREE_PORT) --timeout 60000
+ $(V)$(WAIT_ON_BINARY) http://localhost:$(FREE_PORT) --timeout 60000 || (echo ==dump coolwsd.log== && cat $(COOLWSD_OUTPUT) && exit 1)
$(V)echo
endef