summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJan-Marek Glogowski <glogow@fbihome.de>2020-07-11 02:57:25 +0200
committerMichael Meeks <michael.meeks@collabora.com>2020-07-11 11:59:14 +0200
commitc45d8197a6fbaee4aa7de19d336916a451e74b6c (patch)
tree80fad41d96b5858c678eed225167866a1dfc7232 /configure.ac
parentRe-factoring to make re-use in a next-gen iOS app easier (diff)
downloadonline-c45d8197a6fbaee4aa7de19d336916a451e74b6c.tar.gz
online-c45d8197a6fbaee4aa7de19d336916a451e74b6c.zip
Report better SSL state for mobile apps
I tried to enable SSL, because I didn't want to be insecure, as stated by the message "insecure: ssl disabled". But for mobile apps the whole communication is actually local and SSL no any support option, so this is hopefully a better message. Change-Id: I35c50772ed49910997b80e6f449483da21775120 Reviewed-on: https://gerrit.libreoffice.org/c/online/+/98552 Tested-by: Jenkins Tested-by: Jenkins CollaboraOffice <jenkinscollaboraoffice@gmail.com> Reviewed-by: Michael Meeks <michael.meeks@collabora.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 6 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 7d2f0a4f04..c678540db9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -915,7 +915,7 @@ mobile_app=
ENABLE_MOBILEAPP=
MOBILEAPP=0
AC_MSG_CHECKING([Is this a mobile app])
-if test "$enable_gtkapp" = "yes" -o "$enable_iosapp" = "yes" -o "$enable_androidapp"; then
+if test "$enable_gtkapp" = "yes" -o "$enable_iosapp" = "yes" -o "$enable_androidapp" = "yes"; then
AC_MSG_RESULT([Yes])
mobile_app=true;
MOBILEAPP=1
@@ -933,7 +933,11 @@ if test "$enable_ssl" != "no" -a "$mobile_app" != "true"; then
ENABLE_SSL=true
AC_DEFINE([ENABLE_SSL],1,[Whether to enable SSL])
else
- ssl_msg="insecure: ssl disabled"
+ if test "$mobile_app" != "true"; then
+ ssl_msg="insecure: ssl disabled"
+ else
+ ssl_msg="invalid for mobile apps (disabled)"
+ fi
ENABLE_SSL=false
AC_DEFINE([ENABLE_SSL],0,[Whether to enable SSL])
fi