summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorTamás Zolnai <tamas.zolnai@collabora.com>2020-01-23 17:14:09 +0100
committerTamás Zolnai <tamas.zolnai@collabora.com>2020-01-23 21:02:46 +0100
commitaaab96fd122c24bde3eed6460e25453fa3d02171 (patch)
tree35401f21ca0b69fef338c5dd6149f06a40e48449 /configure.ac
parentDesktop: id document-name-input: set input field based on its value (diff)
downloadonline-aaab96fd122c24bde3eed6460e25453fa3d02171.tar.gz
online-aaab96fd122c24bde3eed6460e25453fa3d02171.zip
cypress: make chrome check depend on enable_cypress flag.
Change-Id: I0e61ef55be68991ae6d55247d93beb0cd6913084 Reviewed-on: https://gerrit.libreoffice.org/c/online/+/87292 Reviewed-by: Tamás Zolnai <tamas.zolnai@collabora.com> Tested-by: Tamás Zolnai <tamas.zolnai@collabora.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 6 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 6cd5171123..f56bcab1b9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -885,10 +885,12 @@ AS_IF([test `uname -s` = "Linux"],
AC_MSG_ERROR([This node version is old, upgrade to >= 6.0.0])
fi
fi
- AC_PATH_PROGS(CHROME, chrome google-chrome chromium, no)
- if test "$CHROME" = "no"; then
- # Only a warning till these tests are not part of toplevel 'make check'.
- AC_MSG_WARN([chrome or chromium is required to run the JS tests, but not installed])
+ if test "$enable_cypress" = "yes"; then
+ AC_PATH_PROGS(CHROME, chrome google-chrome chromium, no)
+ if test "$CHROME" = "no"; then
+ # Only a warning till these tests are not part of toplevel 'make check'.
+ AC_MSG_WARN([chrome or chromium is required to run the JS tests, but not installed])
+ fi
fi
])