summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorHenry Castro <hcastro@collabora.com>2020-03-05 10:44:25 -0400
committerHenry Castro <hcastro@collabora.com>2020-03-06 14:18:05 +0100
commite99f0da28d7e00db98e6476d997eadd9be13e8c3 (patch)
tree3321cf0aa9e7952017a8067f6b2476d577f9583f /Makefile.am
parentOn clicking last-sheet button, scroll to last tab (diff)
downloadonline-e99f0da28d7e00db98e6476d997eadd9be13e8c3.tar.gz
online-e99f0da28d7e00db98e6476d997eadd9be13e8c3.zip
wsd: makefile: allow to set GDB Front Ends
Change-Id: I5b667938b25d8fe63d6c378cb383e357a071e134 Reviewed-on: https://gerrit.libreoffice.org/c/online/+/90022 Tested-by: Jenkins CollaboraOffice <jenkinscollaboraoffice@gmail.com> Reviewed-by: Henry Castro <hcastro@collabora.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 9d04569b2c..5a67a5fafe 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -303,6 +303,7 @@ if HAVE_LO_PATH
SYSTEM_STAMP = @SYSTEMPLATE_PATH@/system_stamp
CAPABILITIES = $(if @ENABLE_SETCAP@,true,false)
+RUN_GDB = $(if $(GDB_FRONTEND),$(GDB_FRONTEND),gdb --tui --args)
$(SYSTEM_STAMP) : ${top_srcdir}/loolwsd-systemplate-setup
if test "z@SYSTEMPLATE_PATH@" != "z"; then rm -rf "@SYSTEMPLATE_PATH@"; fi
@@ -380,7 +381,7 @@ run-gdb: all @JAILS_PATH@
@cp $(abs_top_srcdir)/test/data/hello.odt $(abs_top_srcdir)/test/data/hello-world.odt
@cp $(abs_top_srcdir)/test/data/hello.ods $(abs_top_srcdir)/test/data/hello-world.ods
@cp $(abs_top_srcdir)/test/data/hello.odp $(abs_top_srcdir)/test/data/hello-world.odp
- gdb --tui --args \
+ $(RUN_GDB) \
./loolwsd --o:security.capabilities="false" \
--o:sys_template_path="@SYSTEMPLATE_PATH@" \
--o:child_root_path="@JAILS_PATH@" --o:storage.filesystem[@allow]=true \