summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorAshod Nakashian <ashod.nakashian@collabora.co.uk>2023-04-20 11:36:14 -0400
committerAshod Nakashian <Ashod@users.noreply.github.com>2023-05-02 19:54:31 -0400
commitd8d88c740dc67eb51819fb038434fa3386d8ce7e (patch)
treedba494e7e9c95a7d43fb5d4fbde879585a8dbb74 /Makefile.am
parentmake: cosmetics (diff)
downloadonline-d8d88c740dc67eb51819fb038434fa3386d8ce7e.tar.gz
online-d8d88c740dc67eb51819fb038434fa3386d8ce7e.zip
make: generate compile_commands.json for all .cpp files
Best to have all .cpp files in compile_commands.json so they can all benefit from the tools that leverage it. So now we recursively generate the file for all .cpp files in all subdirectories. Most notably, now all test files are included. Change-Id: I312d812463607b32fe6b9e83b10900c17ae86185 Signed-off-by: Ashod Nakashian <ashod.nakashian@collabora.co.uk>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 1 insertions, 7 deletions
diff --git a/Makefile.am b/Makefile.am
index 9de9c357db..586affc9d4 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -122,8 +122,6 @@ if ENABLE_SSL
shared_sources += net/Ssl.cpp
endif
-shared_json = $(patsubst %.cpp,%.cmd,$(shared_sources))
-
coolwsd_sources = common/Crypto.cpp \
wsd/Admin.cpp \
wsd/AdminModel.cpp \
@@ -142,8 +140,6 @@ coolwsd_sources = common/Crypto.cpp \
wsd/ProofKey.cpp \
wsd/QuarantineUtil.cpp
-coolwsd_json = $(patsubst %.cpp,%.cmd,$(coolwsd_sources))
-
coolwsd_SOURCES = $(coolwsd_sources) \
$(shared_sources)
@@ -182,8 +178,6 @@ coolforkit_sources = kit/ChildSession.cpp \
kit/ForKit.cpp \
kit/Kit.cpp
-coolforkit_json = $(patsubst %.cpp,%.cmd,$(coolforkit_sources))
-
coolforkit_SOURCES = $(coolforkit_sources) \
$(shared_sources)
@@ -595,7 +589,7 @@ CLANGXX_COMPILE_FLAGS=clang++ $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) \
JSON_COMPILE_FLAGS=$(subst ",\",$(subst \,\\,$(CLANGXX_COMPILE_FLAGS)))
-JSON_COMPILE_SRC = $(coolwsd_json) $(coolforkit_json) $(shared_json)
+JSON_COMPILE_SRC = $(patsubst %.cpp,%.cmd,$(wildcard **/*.cpp))
$(eval $(call file_targets,$(JSON_COMPILE_SRC)))