summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorTor Lillqvist <tml@collabora.com>2021-06-17 13:31:27 +0300
committerTor Lillqvist <tml@iki.fi>2021-06-21 12:43:17 +0300
commitd6569159b7afc5b9453bfe61f1e0b0c42c8954b7 (patch)
tree5e63976a73e15f8d2507f9c93ef2f49cdce828db /Makefile.am
parentGuard against multiple threads writing to the Trace Event log file (diff)
downloadonline-d6569159b7afc5b9453bfe61f1e0b0c42c8954b7.tar.gz
online-d6569159b7afc5b9453bfe61f1e0b0c42c8954b7.zip
Output a Trace Event metadata event identifying each named thread
Move the generic dummy implementation of TraceEvent::emitOneRecording() to a source file of its own. (That is the one which is used in test and tool executables.) Signed-off-by: Tor Lillqvist <tml@collabora.com> Change-Id: I81cab07e5a6852b42d278a5446c13c3825cf546e
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 6 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index a3578ddc2a..dbb997c2b2 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -154,12 +154,14 @@ noinst_PROGRAMS += loolwsd_fuzzer
endif
connect_SOURCES = tools/Connect.cpp \
+ common/DummyTraceEventEmitter.cpp \
common/Log.cpp \
common/Protocol.cpp \
common/StringVector.cpp \
common/Util.cpp
lokitclient_SOURCES = common/Log.cpp \
+ common/DummyTraceEventEmitter.cpp \
tools/KitClient.cpp \
common/Protocol.cpp \
common/StringVector.cpp \
@@ -210,6 +212,7 @@ httpresponse_fuzzer_SOURCES = \
httpresponse_fuzzer_LDFLAGS = -fsanitize=fuzzer $(AM_LDFLAGS)
clientnb_SOURCES = net/clientnb.cpp \
+ common/DummyTraceEventEmitter.cpp \
common/Log.cpp \
common/StringVector.cpp \
common/Util.cpp
@@ -222,18 +225,21 @@ loolconvert_SOURCES = tools/Tool.cpp
loolstress_CPPFLAGS = -DTDOC=\"$(abs_top_srcdir)/test/data\" ${include_paths}
loolstress_SOURCES = tools/Stress.cpp \
+ common/DummyTraceEventEmitter.cpp \
common/Protocol.cpp \
common/StringVector.cpp \
common/Log.cpp \
common/Util.cpp
loolconfig_SOURCES = tools/Config.cpp \
+ common/DummyTraceEventEmitter.cpp \
common/Crypto.cpp \
common/Log.cpp \
common/StringVector.cpp \
common/Util.cpp
loolsocketdump_SOURCES = tools/WebSocketDump.cpp \
+ common/DummyTraceEventEmitter.cpp \
$(shared_sources)
wsd_headers = wsd/Admin.hpp \