summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorAshod Nakashian <ashod.nakashian@collabora.co.uk>2021-05-26 22:04:02 -0400
committerAshod Nakashian <Ashod@users.noreply.github.com>2022-08-17 08:55:12 -0400
commita87d1ae54fc907651df278c0e673a6a823ee81b0 (patch)
tree71be98862d7ad448df5a7f5fa3d1bfd73599ce6c /Makefile.am
parentwsd: fix uninitialized DocumentBroker::_savingTimeout (diff)
downloadonline-a87d1ae54fc907651df278c0e673a6a823ee81b0.tar.gz
online-a87d1ae54fc907651df278c0e673a6a823ee81b0.zip
wsd: add HttpEcho fuzzer
This is a full round-trip http fuzzer. It can achieve >1000 iterations per second on a single 2 Ghz core, even while going through the network loopback layer. The advantage is that more networking code is fuzzed this way, including not just the http code, but also the sockets. Change-Id: I75d21bd0e25221ee6621097a2605d62c4bb2ae4d Signed-off-by: Ashod Nakashian <ashod.nakashian@collabora.co.uk>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am14
1 files changed, 13 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index f249470d44..85dba2797c 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -151,7 +151,8 @@ if ENABLE_LIBFUZZER
noinst_PROGRAMS += \
admin_fuzzer \
clientsession_fuzzer \
- httpresponse_fuzzer
+ httpresponse_fuzzer \
+ httpecho_fuzzer
endif
connect_SOURCES = tools/Connect.cpp \
@@ -210,6 +211,17 @@ httpresponse_fuzzer_SOURCES = \
fuzzer/HttpResponse.cpp
httpresponse_fuzzer_LDFLAGS = -fsanitize=fuzzer $(AM_LDFLAGS)
+httpecho_fuzzer_CPPFLAGS = \
+ -DKIT_IN_PROCESS=1 \
+ $(AM_CPPFLAGS) \
+ -I${top_srcdir}/test
+httpecho_fuzzer_SOURCES = \
+ $(loolwsd_sources) \
+ $(loolforkit_sources) \
+ $(shared_sources) \
+ fuzzer/HttpEcho.cpp
+httpecho_fuzzer_LDFLAGS = -fsanitize=fuzzer $(AM_LDFLAGS)
+
endif # ENABLE_LIBFUZZER
clientnb_SOURCES = net/clientnb.cpp \