summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorAshod Nakashian <ashod.nakashian@collabora.co.uk>2023-02-28 06:30:00 -0500
committerCaolán McNamara <caolanm@gmail.com>2023-11-27 10:48:44 +0000
commita624a704ac58fdd4599ecef4fc3f174bf45659c6 (patch)
tree798f085007141b49086cdff3208a0b0e80db3fac /Makefile.am
parentwasm: pass the docURL to the wasm app (diff)
downloadonline-a624a704ac58fdd4599ecef4fc3f174bf45659c6.tar.gz
online-a624a704ac58fdd4599ecef4fc3f174bf45659c6.zip
wsd: add StorageConnectionManager
StorageConnectionManager centralizes the connection creation and management of Storage sockets and related bits. This is needed as we move to a more async model of communicating with the Storage. Change-Id: I7a44c95c113bbc536e922b5aa3f7cf9b71917c22 Signed-off-by: Ashod Nakashian <ashod.nakashian@collabora.co.uk>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 34f207357f..b685f31d04 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -139,6 +139,7 @@ coolwsd_sources = common/Crypto.cpp \
wsd/FileServerUtil.cpp \
wsd/RequestDetails.cpp \
wsd/Storage.cpp \
+ wsd/StorageConnectionManager.cpp \
wsd/HostUtil.cpp \
wsd/TileCache.cpp \
wsd/ProofKey.cpp \
@@ -285,6 +286,7 @@ wsd_headers = wsd/Admin.hpp \
wsd/SenderQueue.hpp \
wsd/ServerURL.hpp \
wsd/Storage.hpp \
+ wsd/StorageConnectionManager.hpp \
wsd/TileCache.hpp \
wsd/TileDesc.hpp \
wsd/TraceFile.hpp \