summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMiklos Vajna <vmiklos@collabora.com>2020-07-16 10:43:57 +0200
committerMiklos Vajna <vmiklos@collabora.com>2020-07-16 16:34:35 +0200
commit9b620cb40bf69147d2aa20902b740503faf6c391 (patch)
treef7f13e4bc9edec20453b951dbe9ed813040c2a9c /Makefile.am
parentwsd: fix log order in DocumentBroker::sendRequestedTiles() (diff)
downloadonline-9b620cb40bf69147d2aa20902b740503faf6c391.tar.gz
online-9b620cb40bf69147d2aa20902b740503faf6c391.zip
libfuzzer: fix build
libfuzzer only produces fuzzer binaries, not a loolwsd binary, so don't expect it in the libfuzzer case. Change-Id: Ib818667031665aa60a447ddd5edd3a09bca76e18 Reviewed-on: https://gerrit.libreoffice.org/c/online/+/98910 Tested-by: Jenkins Tested-by: Jenkins CollaboraOffice <jenkinscollaboraoffice@gmail.com> Reviewed-by: Miklos Vajna <vmiklos@collabora.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am20
1 files changed, 18 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index d75de4b49f..e2c4b57e60 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -323,7 +323,11 @@ EXTRA_DIST = discovery.xml \
scripts/unocommands.py \
$(man_MANS)
+if ENABLE_LIBFUZZER
+CLEANUP_COMMAND=true
+else
CLEANUP_COMMAND=if test -s ./loolwsd; then echo "Cleaning up..." && ./loolwsd --disable-lool-user-checking --cleanup --o:logging.level=trace; fi
+endif
if HAVE_LO_PATH
@@ -340,9 +344,15 @@ else
echo "Skipping capability setting"
endif
+if ENABLE_LIBFUZZER
+CLEANUP_DEPS=
+else
+CLEANUP_DEPS=loolwsd
+endif
+
# Build loolwsd and loolmount first, so we can cleanup before updating
# the systemplate directory, which we can't rm if it's mounted.
-$(SYSTEM_STAMP): ${top_srcdir}/loolwsd-systemplate-setup loolwsd caps_bins
+$(SYSTEM_STAMP): ${top_srcdir}/loolwsd-systemplate-setup $(CLEANUP_DEPS) caps_bins
$(CLEANUP_COMMAND)
if test "z@SYSTEMPLATE_PATH@" != "z"; then rm -rf "@SYSTEMPLATE_PATH@"; fi
${top_srcdir}/loolwsd-systemplate-setup "@SYSTEMPLATE_PATH@" "@LO_PATH@" && touch $@
@@ -483,7 +493,13 @@ endif
# installing the RPM or Debian package.
.PHONY: caps_bins cleanup
-all-local: loolwsd caps_bins @JAILS_PATH@ $(SYSTEM_STAMP)
+if ENABLE_LIBFUZZER
+ALL_LOCAL_DEPS=
+else
+ALL_LOCAL_DEPS=loolwsd
+endif
+
+all-local: $(ALL_LOCAL_DEPS) caps_bins @JAILS_PATH@ $(SYSTEM_STAMP)
# just run the build without any tests
build-nocheck: all-am