summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorAshod Nakashian <ashod.nakashian@collabora.co.uk>2022-04-14 19:05:26 -0400
committerAshod Nakashian <Ashod@users.noreply.github.com>2022-04-20 07:12:03 -0400
commit96adaa15d1313715a26527a84dfdf6d458a2bfc3 (patch)
tree1c9c8cd733944fe89732693225e3f7fe052d7e1e /Makefile.am
parentconfigure: choose the correct sanitizer library when fuzzing (diff)
downloadonline-96adaa15d1313715a26527a84dfdf6d458a2bfc3.tar.gz
online-96adaa15d1313715a26527a84dfdf6d458a2bfc3.zip
wsd: kill coolwsd_fuzzer
coolwsd_fuzzer predates actual fuzzing with libfuzzer and is currently unsused. Change-Id: Id095b165943ba14dbf525ddc607ad329f5d952d4 Signed-off-by: Ashod Nakashian <ashod.nakashian@collabora.co.uk>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am12
1 files changed, 1 insertions, 11 deletions
diff --git a/Makefile.am b/Makefile.am
index 8b53ccadcc..4d4c5059c6 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -79,13 +79,10 @@ AM_LDFLAGS = -pthread -Wl,-E -lpam $(ZLIB_LIBS)
if ENABLE_SSL
AM_LDFLAGS += -lssl -lcrypto
else
-coolwsd_fuzzer_LDADD = -lssl -lcrypto
coolwsd_LDADD = -lssl -lcrypto
coolconfig_LDADD = -lssl -lcrypto
endif
-coolwsd_fuzzer_CPPFLAGS = -DKIT_IN_PROCESS=1 -DFUZZER=1 -DTDOC=\"$(abs_top_srcdir)/test/data\" $(AM_CPPFLAGS)
-
AM_ETAGSFLAGS = --c++-kinds=+p --fields=+iaS --extra=+q -R --totals=yes --exclude=browser *
AM_CTAGSFLAGS = $(AM_ETAGSFLAGS)
@@ -154,8 +151,6 @@ noinst_PROGRAMS += \
admin_fuzzer \
clientsession_fuzzer \
httpresponse_fuzzer
-else
-noinst_PROGRAMS += coolwsd_fuzzer
endif
connect_SOURCES = tools/Connect.cpp \
@@ -182,11 +177,6 @@ coolforkit_json = $(patsubst %.cpp,%.cmd,$(coolforkit_sources))
coolforkit_SOURCES = $(coolforkit_sources) \
$(shared_sources)
-coolwsd_fuzzer_SOURCES = $(coolwsd_sources) \
- $(coolforkit_sources) \
- $(shared_sources) \
- kit/DummyLibreOfficeKit.cpp
-
if ENABLE_LIBFUZZER
admin_fuzzer_CPPFLAGS = \
@@ -425,7 +415,7 @@ clean-local:
if test "z@SYSTEMPLATE_PATH@" != "z"; then rm -rf "@SYSTEMPLATE_PATH@"; fi
rm -rf "${top_srcdir}/loleaflet"
rm -rf loolconfig loolconvert loolforkit loolmap loolmount # kill old binaries
- rm -rf loolwsd loolwsd_fuzzer loolstress loolsocketdump
+ rm -rf loolwsd loolwsd_fuzzer coolwsd_fuzzer loolstress loolsocketdump
if ENABLE_DEBUG
# can write to /tmp/coolwsd.log