summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorHubert Figuière <hub@collabora.com>2024-04-04 14:29:18 -0400
committerAndras Timar <andras.timar@collabora.com>2024-04-10 15:54:56 +0200
commit7a9aa6c6c97b622679f4043e67fbc61ed7e3dec8 (patch)
tree21be062d8d2fac503789bd60af90f77a7f71c6d5 /Makefile.am
parentFix formatting on JQuery join tooltip (diff)
downloadonline-7a9aa6c6c97b622679f4043e67fbc61ed7e3dec8.tar.gz
online-7a9aa6c6c97b622679f4043e67fbc61ed7e3dec8.zip
Makefile: added a target to run with heaptrack
It will launch the gui at the end if found It's much faster than valgrind+massif Signed-off-by: Hubert Figuière <hub@collabora.com> Change-Id: Ied5a00ab634f78bbb0dd24a48a83ae4293183cd4
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 6 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 6388767468..0b2c43a642 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -549,6 +549,12 @@ run-massif-inproc: setup-wsd
valgrind --tool=massif --num-callers=64 --trace-children=no -v \
./coolwsd-inproc $(COMMON_PARAMS) \
--o:logging.file[@enable]=false --o:logging.level=trace
+
+run-heaptrack-inproc: setup-wsd
+ @echo "Launching coolwsd under heaptrack for single process"
+ heaptrack \
+ ./coolwsd-inproc $(COMMON_PARAMS) \
+ --o:logging.file[@enable]=false --o:logging.level=trace
endif
sync-writer: