summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorcodewithvk <vivekpatel7202@gmail.com>2023-05-31 07:01:47 +0000
committerMichael Meeks <michael.meeks@collabora.com>2023-06-03 14:55:58 +0100
commit71039cb0e448c8968617d851da91f2e891edab00 (patch)
treecc1f80e871ecd73cedfa2c37db26c34743de07a7 /Makefile.am
parentNavigator: Fix alignment to coincide w/sidebar properties expanders (diff)
downloadonline-71039cb0e448c8968617d851da91f2e891edab00.tar.gz
online-71039cb0e448c8968617d851da91f2e891edab00.zip
Condense common parameters in Makefile.am
Signed-off-by: codewithvk <vivekpatel7202@gmail.com> Change-Id: Ie3027c63cc31eea2dea2cb0a997d296a24476581
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am33
1 files changed, 15 insertions, 18 deletions
diff --git a/Makefile.am b/Makefile.am
index a96fe521fd..83f9fb21b3 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -460,28 +460,25 @@ setup-wsd: all @JAILS_PATH@
@cp $(abs_top_srcdir)/test/data/hello.odp $(abs_top_srcdir)/test/data/hello-world.odp
@echo
+COMMON_PARAMS = \
+ --o:sys_template_path="@SYSTEMPLATE_PATH@" \
+ --o:security.capabilities="$(CAPABILITIES)" \
+ --o:child_root_path="@JAILS_PATH@" --o:storage.filesystem[@allow]=true \
+ --o:ssl.cert_file_path="$(abs_top_srcdir)/etc/cert.pem" \
+ --o:ssl.key_file_path="$(abs_top_srcdir)/etc/key.pem" \
+ --o:ssl.ca_file_path="$(abs_top_srcdir)/etc/ca-chain.cert.pem" \
+ --o:admin_console.username=admin --o:admin_console.password=admin
+
run: setup-wsd
- ./coolwsd --o:sys_template_path="@SYSTEMPLATE_PATH@" \
- --o:security.capabilities="$(CAPABILITIES)" \
- --o:child_root_path="@JAILS_PATH@" --o:storage.filesystem[@allow]=true \
- --o:ssl.cert_file_path="$(abs_top_srcdir)/etc/cert.pem" \
- --o:ssl.key_file_path="$(abs_top_srcdir)/etc/key.pem" \
- --o:ssl.ca_file_path="$(abs_top_srcdir)/etc/ca-chain.cert.pem" \
- --o:admin_console.username=admin --o:admin_console.password=admin \
- --o:logging.file[@enable]=${OUTPUT_TO_FILE} --o:logging.level=trace \
- --o:trace_event[@enable]=true
+ ./coolwsd $(COMMON_PARAMS) \
+ --o:logging.file[@enable]=${OUTPUT_TO_FILE} --o:logging.level=trace \
+ --o:trace_event[@enable]=true
if ENABLE_DEBUG
run-one: setup-wsd
- ./coolwsd --o:sys_template_path="@SYSTEMPLATE_PATH@" \
- --o:security.capabilities="$(CAPABILITIES)" \
- --o:child_root_path="@JAILS_PATH@" --o:storage.filesystem[@allow]=true \
- --o:ssl.cert_file_path="$(abs_top_srcdir)/etc/cert.pem" \
- --o:ssl.key_file_path="$(abs_top_srcdir)/etc/key.pem" \
- --o:ssl.ca_file_path="$(abs_top_srcdir)/etc/ca-chain.cert.pem" \
- --o:admin_console.username=admin --o:admin_console.password=admin \
- --o:logging.file[@enable]=true --o:logging.level=trace \
- --singlekit
+ ./coolwsd $(COMMON_PARAMS) \
+ --o:logging.file[@enable]=true --o:logging.level=trace \
+ --singlekit
endif
sync-writer: