summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorAshod Nakashian <ashod.nakashian@collabora.co.uk>2024-02-11 11:42:22 -0500
committerAshod Nakashian <Ashod@users.noreply.github.com>2024-02-21 20:13:39 -0500
commit5a82c36680bfcb8d92a841d267236236b7066bcf (patch)
tree2a89a8b55f40684c85048f32bed2ecd1c992f7d6 /Makefile.am
parentcalc: on tab switching document view can be restored to a wrong position (diff)
downloadonline-5a82c36680bfcb8d92a841d267236236b7066bcf.tar.gz
online-5a82c36680bfcb8d92a841d267236236b7066bcf.zip
wsd: move ClientRequestDispatcher to own file
This moves ClientRequestDispatcher and all its direct exclusive dependencies to its own file and adjusts formatting. No functional changes were performed, although namespaces were restored and other minor changes were done for consistency. The resulting file is still rather large at around 2000 lines, but that makes COOLWSD.cpp smaller by about 30% now. Change-Id: I59bcd997ad08702ce7029c6791095e75ad9b23b0 Signed-off-by: Ashod Nakashian <ashod.nakashian@collabora.co.uk>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index e93bcb0819..bb1456f1e7 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -136,6 +136,7 @@ coolwsd_sources = common/Crypto.cpp \
wsd/DocumentBroker.cpp \
wsd/ProxyProtocol.cpp \
wsd/COOLWSD.cpp \
+ wsd/ClientRequestDispatcher.cpp \
wsd/ClientSession.cpp \
wsd/FileServer.cpp \
wsd/ProxyRequestHandler.cpp \
@@ -295,6 +296,7 @@ wsd_headers = wsd/Admin.hpp \
wsd/FileServer.hpp \
wsd/ProxyRequestHandler.hpp \
wsd/COOLWSD.hpp \
+ wsd/ClientRequestDispatcher.hpp \
wsd/ProofKey.hpp \
wsd/RequestDetails.hpp \
wsd/RequestVettingStation.hpp \