summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorAndras Timar <andras.timar@collabora.com>2021-09-25 17:42:40 +0200
committerAndras Timar <andras.timar@collabora.com>2021-09-25 19:04:59 +0200
commit30ef4a62d58acaa03dbbb2586791a0338f2e6292 (patch)
tree5bc8b4fb3c1a3f27e0318538cc129df564bc4153 /Makefile.am
parentNotebookbar: Set menu button without hardcoded px (diff)
downloadonline-30ef4a62d58acaa03dbbb2586791a0338f2e6292.tar.gz
online-30ef4a62d58acaa03dbbb2586791a0338f2e6292.zip
fix Lintian errors: binary-or-shlib-defines-rpath
E: loolwsd: binary-or-shlib-defines-rpath usr/bin/loolconvert /snap/loolwsd/current/usr/lib E: loolwsd: binary-or-shlib-defines-rpath usr/bin/loolconvert /opt/poco/lib These RPATHs are not needed when we statically link poco, as we do with production packages. Signed-off-by: Andras Timar <andras.timar@collabora.com> Change-Id: I5050fe1f1925937388793d443020fdc6a14ec97d
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index c68d68918a..5f6f0f0cd7 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -72,7 +72,7 @@ if !ENABLE_DEBUG
AM_CPPFLAGS += -DNDEBUG
endif
-AM_LDFLAGS = -pthread -Wl,-E,-rpath,/snap/loolwsd/current/usr/lib -lpam $(ZLIB_LIBS)
+AM_LDFLAGS = -pthread -Wl,-E -lpam $(ZLIB_LIBS)
if ENABLE_SSL
AM_LDFLAGS += -lssl -lcrypto