summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorTor Lillqvist <tml@collabora.com>2022-12-08 11:06:48 +0200
committerAndras Timar <andras.timar@collabora.com>2023-01-15 19:46:37 +0100
commit1889fe2016cb8f03940c31372f7b06f9686bd9b9 (patch)
treee01cee48a342cf82500a81d4d8fb12768180e397 /Makefile.am
parentAdd --with-wasm-fallback configure option (diff)
downloadonline-1889fe2016cb8f03940c31372f7b06f9686bd9b9.tar.gz
online-1889fe2016cb8f03940c31372f7b06f9686bd9b9.zip
When we are building WASM we don't build the browser subdirectory
This is how I imagine that this stuff should work: - In one tree you build with --host=wasm32-local-emscripten. This results in only the WASM binary being built, containing C++ code from Collabora Office core and C++ code from Online (to a similar extent as in the iOS, Android, and gtk apps). No HTML and JS for the client's browser is produced in this tree. The embedded filesystem from the corresponding WASM core build could be copied into this tree for use as below. (Or, alternatively the build in the other tree could look into the config.status file in this tree to figure out where to pick up the embedded fs data file.) - In another tree you build with --with-wasm-fallback=<path to the above WASM tree>. Note that the C++ code will be built normally in this case, for Linux. This build results in an otherwise normal COOL build, with the added feature that the COOL server sends the whole document file also to the COOL client whenever it is saved. The HTML and JS browser code will have code that enables receiving the document in this case, plus incremental updates to the document (if possible), and code to detect that the connection to the COOL server is broken and then fall back to using the local WASM in the browser. Obviously the WASM binary and related JS and other data (like the embedded file system from core) will have to be downloaded into the client right at the start, to be present if the connection breaks, but the WASM will likely not need to be started until needed. Signed-off-by: Tor Lillqvist <tml@collabora.com> Change-Id: I945c93451d3f5f0b1bc6ad8550da64e8e6453b6b
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 487aab3e2a..23bcd955a4 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -6,7 +6,7 @@ if ENABLE_GTKAPP
SUBDIRS = gtk browser
else
if ENABLE_WASM
-SUBDIRS = wasm browser
+SUBDIRS = wasm
else !ENABLE_WASM
SUBDIRS = browser
endif !ENABLE_WASM