summaryrefslogtreecommitdiffstats
path: root/test/Makefile.am
diff options
context:
space:
mode:
authorMichael Meeks <michael.meeks@collabora.com>2017-03-02 18:12:52 +0000
committerJan Holesovsky <kendy@collabora.com>2017-03-10 10:47:42 +0100
commitfa6b75634607591cb41975ccc98d9e2a27869e22 (patch)
tree150140b8e9d35938eef24cafd4e979cc1c3c3906 /test/Makefile.am
parentnb: No need to construct a new WebSocketHandler here. (diff)
downloadonline-fa6b75634607591cb41975ccc98d9e2a27869e22.tar.gz
online-fa6b75634607591cb41975ccc98d9e2a27869e22.zip
signal handling: keep track of all socket poll wakeups & wakeup.
Instead of waiting for polls to timeout; wake them up.
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index d849f1372e..1785d62c32 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -39,7 +39,8 @@ wsd_sources = \
../kit/Kit.cpp \
../wsd/TileCache.cpp \
../common/Unit.cpp \
- ../common/Util.cpp
+ ../common/Util.cpp \
+ ../net/Socket.cpp
unittest_CPPFLAGS = -I$(top_srcdir) -DBUILDING_TESTS
unittest_SOURCES = TileQueueTests.cpp WhiteBoxTests.cpp test.cpp $(wsd_sources)