summaryrefslogtreecommitdiffstats
path: root/test/Makefile.am
diff options
context:
space:
mode:
authorMichael Meeks <michael.meeks@collabora.com>2017-09-19 21:16:44 +0100
committerMichael Meeks <michael.meeks@collabora.com>2017-09-19 21:16:44 +0100
commitdef035037967b0ed667439316efd7dcc75d3d92c (patch)
tree8b9a301a84efa8d845d2277a969db17eb687245f /test/Makefile.am
parentAllow unit tests to avoid handleInput. (diff)
downloadonline-def035037967b0ed667439316efd7dcc75d3d92c.tar.gz
online-def035037967b0ed667439316efd7dcc75d3d92c.zip
Re-factor pid hunting code into test.cpp where we can do better.
Prepare the ground for using WSD hooks for this. Change-Id: I5c3e32396b335ad189472ab3a51044372ee304b2
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am25
1 files changed, 20 insertions, 5 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index 005618de93..dc4f7ce4f8 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -43,13 +43,25 @@ wsd_sources = \
../common/Unit.cpp \
../net/Socket.cpp
+test_base_source = \
+ TileQueueTests.cpp \
+ WhiteBoxTests.cpp \
+ $(wsd_sources)
+
+test_all_source = \
+ $(test_base_source) \
+ TileCacheTests.cpp \
+ integration-http-server.cpp \
+ httpwstest.cpp \
+ httpcrashtest.cpp \
+ httpwserror.cpp
+
unittest_CPPFLAGS = -I$(top_srcdir) -DBUILDING_TESTS
-unittest_SOURCES = TileQueueTests.cpp WhiteBoxTests.cpp test.cpp $(wsd_sources)
+unittest_SOURCES = $(test_base_source) test.cpp
unittest_LDADD = $(CPPUNIT_LIBS)
test_CPPFLAGS = -I$(top_srcdir) -DBUILDING_TESTS
-test_SOURCES = TileCacheTests.cpp integration-http-server.cpp \
- httpwstest.cpp httpcrashtest.cpp httpwserror.cpp $(unittest_SOURCES)
+test_SOURCES = $(test_all_source) test.cpp
test_LDADD = $(CPPUNIT_LIBS)
# unit test modules:
@@ -57,7 +69,7 @@ unit_oob_la_SOURCES = UnitOOB.cpp
unit_fuzz_la_SOURCES = UnitFuzz.cpp
unit_admin_la_SOURCES = UnitAdmin.cpp
unit_admin_la_LIBADD = $(CPPUNIT_LIBS)
-unit_client_la_SOURCES = UnitClient.cpp ${test_SOURCES}
+unit_client_la_SOURCES = UnitClient.cpp ${test_base_source}
unit_client_la_LIBADD = $(CPPUNIT_LIBS)
unit_timeout_la_SOURCES = UnitTimeout.cpp
unit_prefork_la_SOURCES = UnitPrefork.cpp
@@ -78,7 +90,10 @@ check-local:
./run_unit.sh --log-file test.log --trs-file test.trs
# FIXME 2: unit-oob.la fails with symbol undefined:
# UnitWSD::testHandleRequest(UnitWSD::TestRequest, UnitHTTPServerRequest&, UnitHTTPServerResponse&) ,
-TESTS = unit-prefork.la unit-tilecache.la unit-timeout.la unit-oauth.la # unit-client.la unit-storage.la unit-admin.la # - enable to run unit-tests in wsd ...
+TESTS = unit-prefork.la unit-tilecache.la unit-timeout.la unit-oauth.la
+# TESTS += unit-client.la
+# TESTS += unit-admin.la
+# TESTS += unit-storage.la
else
TESTS = ${top_builddir}/test/test
endif