summaryrefslogtreecommitdiffstats
path: root/test/Makefile.am
diff options
context:
space:
mode:
authorJan Holesovsky <kendy@collabora.com>2017-08-09 22:02:29 +0200
committerJan Holesovsky <kendy@collabora.com>2017-08-09 22:27:49 +0200
commitcef217ea24c6a048b4c6a4b7ad883621de332a0e (patch)
tree80b08ed65eb1a69fbb31d6d02d809e7f57398bee /test/Makefile.am
parentBetter description of the buttons in case of document conflict. (diff)
downloadonline-cef217ea24c6a048b4c6a4b7ad883621de332a0e.tar.gz
online-cef217ea24c6a048b4c6a4b7ad883621de332a0e.zip
wsd: Fix the OAuth unit test.
Trying to combine the Poco's http server together with our polling loop leads only to problem; so instead let's introduce a hook where we can do the WOPI serving directly in the unit test. Change-Id: Id3fec6ff93c3ad652aa4e0fc6309c5b7639728cb
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am8
1 files changed, 4 insertions, 4 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index 237c2e1a20..9ff9bb4476 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -13,9 +13,9 @@ AM_CXXFLAGS = $(CPPUNIT_CFLAGS) -DTDOC=\"$(top_srcdir)/test/data\" \
-I${top_srcdir}/common -I${top_srcdir}/net -I${top_srcdir}/wsd -I${top_srcdir}/kit
noinst_LTLIBRARIES = \
- unit-timeout.la unit-prefork.la \
- unit-storage.la unit-client.la \
- unit-admin.la unit-tilecache.la \
+ unit-timeout.la unit-prefork.la \
+ unit-storage.la unit-client.la \
+ unit-admin.la unit-tilecache.la \
unit-fuzz.la unit-oob.la unit-oauth.la
MAGIC_TO_FORCE_SHLIB_CREATION = -rpath /dummy
@@ -77,7 +77,7 @@ check-local:
./run_unit.sh --log-file test.log --trs-file test.trs
# FIXME 2: unit-oob.la fails with symbol undefined:
# UnitWSD::testHandleRequest(UnitWSD::TestRequest, UnitHTTPServerRequest&, UnitHTTPServerResponse&) ,
-TESTS = unit-prefork.la unit-tilecache.la unit-timeout.la # unit-client.la # - enable to run unit-tests in wsd ...
+TESTS = unit-prefork.la unit-tilecache.la unit-timeout.la unit-oauth.la # unit-client.la unit-storage.la unit-admin.la # - enable to run unit-tests in wsd ...
else
TESTS = ${top_builddir}/test/test
endif