summaryrefslogtreecommitdiffstats
path: root/test/Makefile.am
diff options
context:
space:
mode:
authorJan Holesovsky <kendy@collabora.com>2017-04-05 15:44:44 +0200
committerJan Holesovsky <kendy@collabora.com>2017-04-05 15:45:39 +0200
commitb9d1fde7465df8724805011e912c977c269a670c (patch)
treed674bb3477b05abbec53f6db6e8b79097928488c /test/Makefile.am
parentloleaflet: Fix loop which fetches view ids from username (diff)
downloadonline-b9d1fde7465df8724805011e912c977c269a670c.tar.gz
online-b9d1fde7465df8724805011e912c977c269a670c.zip
Run fc-cache before running the unit tests too.
Change-Id: I5d0cc0a1299cfdf1dc0e421d5fab8e2705a258ff
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index 2935e6a065..754f0f12cc 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -69,6 +69,7 @@ endif
if HAVE_LO_PATH
check-local:
+ @fc-cache "@LO_PATH@"/share/fonts/truetype
./run_unit.sh --log-file test.log --trs-file test.trs
# FIXME 2: unit-oob.la fails with symbol undefined:
# UnitWSD::testHandleRequest(UnitWSD::TestRequest, UnitHTTPServerRequest&, UnitHTTPServerResponse&) ,
@@ -83,6 +84,7 @@ LA_LOG_DRIVER = ${top_srcdir}/test/run_unit.sh
EXTRA_DIST = data/hello.odt data/hello.txt $(test_SOURCES) $(unittest_SOURCES) run_unit.sh
check_valgrind: all
+ @fc-cache "@LO_PATH@"/share/fonts/truetype
./run_unit.sh --log-file test.log --trs-file test.trs --valgrind
# run unittest during the normal build
@@ -90,4 +92,5 @@ all-local: unittest
@echo
@echo "Running build-time unit tests. For more thorough testing, please run 'make check'."
@echo
+ @fc-cache "@LO_PATH@"/share/fonts/truetype
@${top_builddir}/test/unittest 2> unittest.log || { cat unittest.log ; exit 1 ; }