summaryrefslogtreecommitdiffstats
path: root/test/Makefile.am
diff options
context:
space:
mode:
authorHenry Castro <hcastro@collabora.com>2017-08-03 17:05:48 -0400
committerHenry Castro <hcastro@collabora.com>2017-08-03 17:11:00 -0400
commita262b7d7ba4a8ff9832446849662a5516e53db53 (patch)
tree410c684a73b1f1d507a30803ed5a93562507bf4c /test/Makefile.am
parentloleaflet: graphic selection can get misplaced if mouse is moved fast (diff)
downloadonline-a262b7d7ba4a8ff9832446849662a5516e53db53.tar.gz
online-a262b7d7ba4a8ff9832446849662a5516e53db53.zip
wsd: OAuth token passing
MS-WOPI: "The following HTTP header MUST be included in all WOPI requests." "Authorization "Bearer" and <token>" Change-Id: Ie5327286e93b86a49a0248ff5886bf3ea99df768
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index f7f4c090cc..237c2e1a20 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -16,7 +16,7 @@ noinst_LTLIBRARIES = \
unit-timeout.la unit-prefork.la \
unit-storage.la unit-client.la \
unit-admin.la unit-tilecache.la \
- unit-fuzz.la unit-oob.la
+ unit-fuzz.la unit-oob.la unit-oauth.la
MAGIC_TO_FORCE_SHLIB_CREATION = -rpath /dummy
AM_LDFLAGS = -pthread -module $(MAGIC_TO_FORCE_SHLIB_CREATION) $(ZLIB_LIBS)
@@ -62,6 +62,8 @@ unit_timeout_la_SOURCES = UnitTimeout.cpp
unit_prefork_la_SOURCES = UnitPrefork.cpp
unit_storage_la_SOURCES = UnitStorage.cpp
unit_tilecache_la_SOURCES = UnitTileCache.cpp
+unit_oauth_la_SOURCES = UnitOAuth.cpp
+unit_oauth_la_LIBADD = $(CPPUNIT_LIBS)
if HAVE_LO_PATH
SYSTEM_STAMP = @SYSTEMPLATE_PATH@/system_stamp