summaryrefslogtreecommitdiffstats
path: root/test/Makefile.am
diff options
context:
space:
mode:
authorJan Holesovsky <kendy@collabora.com>2017-02-24 20:52:36 +0100
committerJan Holesovsky <kendy@collabora.com>2017-03-10 10:47:39 +0100
commita1a46c240e383af7116e70c8689cc2fcb2a927fd (patch)
treef4e94a9090c7b26a88df3f127b799126ae34352f /test/Makefile.am
parentnb: Comment out the POCO server in loolwsd. (diff)
downloadonline-a1a46c240e383af7116e70c8689cc2fcb2a927fd.tar.gz
online-a1a46c240e383af7116e70c8689cc2fcb2a927fd.zip
nb: Use the non-blocking socket in the loolwsd.
This so far only builds, but I did not even try to run it yet. Change-Id: Iceacb5fc5c8994726508e8ea00bd495d758391a8
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index 7efa3f1056..167c436e55 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -10,7 +10,7 @@ check_PROGRAMS = test
noinst_PROGRAMS = test unittest
AM_CXXFLAGS = $(CPPUNIT_CFLAGS) -DTDOC=\"$(top_srcdir)/test/data\" \
- -I${top_srcdir}/common -I${top_srcdir}/wsd -I${top_srcdir}/kit
+ -I${top_srcdir}/common -I${top_srcdir}/net -I${top_srcdir}/wsd -I${top_srcdir}/kit
noinst_LTLIBRARIES = \
unit-timeout.la unit-prefork.la \
@@ -36,6 +36,7 @@ wsd_sources = \
../common/Protocol.cpp \
../common/Session.cpp \
../common/MessageQueue.cpp \
+ ../net/WebSocketHandler.cpp \
../kit/Kit.cpp \
../wsd/TileCache.cpp \
../common/Unit.cpp \