summaryrefslogtreecommitdiffstats
path: root/test/Makefile.am
diff options
context:
space:
mode:
authorAshod Nakashian <ashod.nakashian@collabora.co.uk>2016-12-17 09:54:19 -0500
committerAshod Nakashian <ashnakash@gmail.com>2016-12-19 05:44:40 +0000
commit8099b84c3e07d0a81db37b5bc4f3cf686125afbd (patch)
tree364f5f6f0da665e84a951d59eade3b5d23aceb21 /test/Makefile.am
parentloolwsd: better to poll less frequently (diff)
downloadonline-8099b84c3e07d0a81db37b5bc4f3cf686125afbd.tar.gz
online-8099b84c3e07d0a81db37b5bc4f3cf686125afbd.zip
loolwsd: run whitebox unittests with `make check`
Change-Id: I4354e1f42f33a5b2181a895077e1e16abb4e2c99 Reviewed-on: https://gerrit.libreoffice.org/32154 Reviewed-by: Ashod Nakashian <ashnakash@gmail.com> Tested-by: Ashod Nakashian <ashnakash@gmail.com>
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am10
1 files changed, 5 insertions, 5 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index 68f8c81d40..287b09d612 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -41,15 +41,15 @@ wsd_sources = \
../common/Unit.cpp \
../common/Util.cpp
-test_CPPFLAGS = -I$(top_srcdir) -DBUILDING_TESTS
-test_SOURCES = TileCacheTests.cpp integration-http-server.cpp \
- httpwstest.cpp httpcrashtest.cpp httpwserror.cpp test.cpp $(wsd_sources)
-test_LDADD = $(CPPUNIT_LIBS)
-
unittest_CPPFLAGS = -I$(top_srcdir) -DBUILDING_TESTS
unittest_SOURCES = TileQueueTests.cpp WhiteBoxTests.cpp test.cpp $(wsd_sources)
unittest_LDADD = $(CPPUNIT_LIBS)
+test_CPPFLAGS = -I$(top_srcdir) -DBUILDING_TESTS
+test_SOURCES = TileCacheTests.cpp integration-http-server.cpp \
+ httpwstest.cpp httpcrashtest.cpp httpwserror.cpp $(unittest_SOURCES)
+test_LDADD = $(CPPUNIT_LIBS)
+
# unit test modules:
unit_oob_la_SOURCES = UnitOOB.cpp
unit_fuzz_la_SOURCES = UnitFuzz.cpp