summaryrefslogtreecommitdiffstats
path: root/test/Makefile.am
diff options
context:
space:
mode:
authorPranav Kant <pranavk@collabora.co.uk>2017-03-31 14:42:10 +0530
committerpranavk <pranavk@collabora.co.uk>2017-03-31 09:17:56 +0000
commit453a452ff9d1dcee7e26d0243ddd79dca32c0f13 (patch)
treeaf059f40ce90b421f5f66208f79306a4a147f813 /test/Makefile.am
parentloleaflet: Annotate readonly users in userlist (diff)
downloadonline-453a452ff9d1dcee7e26d0243ddd79dca32c0f13.tar.gz
online-453a452ff9d1dcee7e26d0243ddd79dca32c0f13.zip
Makefile: Simplify and link zlib properly
Without this, online doesn't link, atleast for me. The problem seems to be because in presence of target specific _LDFLAGS, AM_LDFLAGS is ignored and it is only the latter where we are specifying ZLIB_LIBS. Further, since the LDFLAGS values are same for all targets, we can simplify here and rather use AM_LDFLAGS and remove all target specific LDFLAGS. Change-Id: I2f1c30c7f34b32c638a4ac60fab709b32f1e6c9a Reviewed-on: https://gerrit.libreoffice.org/35959 Reviewed-by: pranavk <pranavk@collabora.co.uk> Tested-by: pranavk <pranavk@collabora.co.uk>
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index 9008efa162..6be2a53566 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -20,7 +20,7 @@ noinst_LTLIBRARIES = \
unit-minsocketbuffersize.la
MAGIC_TO_FORCE_SHLIB_CREATION = -rpath /dummy
-AM_LDFLAGS = -pthread -module $(MAGIC_TO_FORCE_SHLIB_CREATION)
+AM_LDFLAGS = -pthread -module $(MAGIC_TO_FORCE_SHLIB_CREATION) $(ZLIB_LIBS)
# We work around some of the mess of using the same sources both on
# the server side and here in unit tests with conditional compilation