summaryrefslogtreecommitdiffstats
path: root/test/Makefile.am
diff options
context:
space:
mode:
authorJan Holesovsky <kendy@collabora.com>2017-09-27 14:13:43 +0200
committerJan Holesovsky <kendy@collabora.com>2017-09-27 16:37:16 +0200
commit3141cfc99ba2e2fb3878e95373a2fa48a76205a5 (patch)
tree1216c16e3f4163fcc55f56eb89cfd90e94aa5fc7 /test/Makefile.am
parentSeparate the fake wopi server to an own class. (diff)
downloadonline-3141cfc99ba2e2fb3878e95373a2fa48a76205a5.tar.gz
online-3141cfc99ba2e2fb3878e95373a2fa48a76205a5.zip
PutFile ext: X-LOOL-WOPI-IsModifiedByUser unit test.
Change-Id: I0b1ffc74dbbc771f0dcb68f87d46af3ba469ae9e Reviewed-on: https://gerrit.libreoffice.org/42855 Reviewed-by: pranavk <pranavk@collabora.co.uk> Tested-by: pranavk <pranavk@collabora.co.uk>
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am7
1 files changed, 5 insertions, 2 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index 5709496785..7ee4bcf2ba 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -16,7 +16,8 @@ noinst_LTLIBRARIES = \
unit-timeout.la unit-prefork.la \
unit-storage.la unit-client.la \
unit-admin.la unit-tilecache.la \
- unit-fuzz.la unit-oob.la unit-oauth.la
+ unit-fuzz.la unit-oob.la unit-oauth.la \
+ unit-wopi.la
MAGIC_TO_FORCE_SHLIB_CREATION = -rpath /dummy
AM_LDFLAGS = -pthread -module $(MAGIC_TO_FORCE_SHLIB_CREATION) $(ZLIB_LIBS)
@@ -77,6 +78,8 @@ unit_storage_la_SOURCES = UnitStorage.cpp
unit_tilecache_la_SOURCES = UnitTileCache.cpp
unit_oauth_la_SOURCES = UnitOAuth.cpp
unit_oauth_la_LIBADD = $(CPPUNIT_LIBS)
+unit_wopi_la_SOURCES = UnitWOPI.cpp
+unit_wopi_la_LIBADD = $(CPPUNIT_LIBS)
if HAVE_LO_PATH
SYSTEM_STAMP = @SYSTEMPLATE_PATH@/system_stamp
@@ -90,7 +93,7 @@ check-local:
./run_unit.sh --log-file test.log --trs-file test.trs
# FIXME 2: unit-oob.la fails with symbol undefined:
# UnitWSD::testHandleRequest(UnitWSD::TestRequest, UnitHTTPServerRequest&, UnitHTTPServerResponse&) ,
-TESTS = unit-prefork.la unit-tilecache.la unit-timeout.la unit-oauth.la
+TESTS = unit-prefork.la unit-tilecache.la unit-timeout.la unit-oauth.la unit-wopi.la
# TESTS = unit-client.la
# TESTS += unit-admin.la
# TESTS += unit-storage.la