summaryrefslogtreecommitdiffstats
path: root/test/Makefile.am
diff options
context:
space:
mode:
authorAshod Nakashian <ashod.nakashian@collabora.co.uk>2016-12-10 22:33:45 -0500
committerAshod Nakashian <ashnakash@gmail.com>2016-12-12 05:19:04 +0000
commit233cb94eff8cdd3430d8626651494bdcd6f7d76f (patch)
tree396b9e8e6382dafb9b13ad67a269e22a6c847368 /test/Makefile.am
parentloolwsd: correct logging (diff)
downloadonline-233cb94eff8cdd3430d8626651494bdcd6f7d76f.tar.gz
online-233cb94eff8cdd3430d8626651494bdcd6f7d76f.zip
loolwsd: SenderQueue to hold messages to send to clients
This adds SenderQueue and a wrapper of messages to send back to clients. Currently no threading takes place, but the messages are pumped through the queue nonetheless. Change-Id: Id9997539c0a2a351cbf406f649c268dd3643e88e Reviewed-on: https://gerrit.libreoffice.org/31883 Reviewed-by: Ashod Nakashian <ashnakash@gmail.com> Tested-by: Ashod Nakashian <ashnakash@gmail.com>
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index 98a8ce9f16..e00e172e83 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -35,7 +35,8 @@ wsd_sources = \
../common/Log.cpp \
../common/Protocol.cpp \
../common/Session.cpp \
- ../common/MessageQueue.cpp \
+ ../common/MessageQueue.cpp \
+ ../common/SenderQueue.cpp \
../kit/Kit.cpp \
../wsd/TileCache.cpp \
../common/Unit.cpp \