summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMichael Meeks <michael.meeks@collabora.com>2018-04-17 14:01:49 +0100
committerMichael Meeks <michael.meeks@collabora.com>2018-04-17 16:50:48 +0100
commitf68d54e02a43738754ba82a40ab42644cc6565aa (patch)
treefcf609c8033157918eb9c3fbd5e2403caf0a5c88 /Makefile.am
parentMove UnitHTTP code to header to avoid linking trouble. (diff)
downloadonline-f68d54e02a43738754ba82a40ab42644cc6565aa.tar.gz
online-f68d54e02a43738754ba82a40ab42644cc6565aa.zip
Initial websocket test tool for remote admin connections.
Change-Id: I8be2068bf7d77c70720a044556d11f5fc80b2f0c
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 6 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index bbff1083e4..6aedc561c6 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -2,7 +2,9 @@ SUBDIRS = . test loleaflet
export ENABLE_DEBUG
-bin_PROGRAMS = loolwsd loolforkit loolmap loolmount looltool loolstress loolconfig
+bin_PROGRAMS = \
+ loolwsd loolforkit loolmap loolmount \
+ looltool loolstress loolconfig loolsocketdump
dist_bin_SCRIPTS = loolwsd-systemplate-setup
@@ -131,6 +133,9 @@ loolconfig_SOURCES = tools/Config.cpp \
common/Log.cpp \
common/Util.cpp
+loolsocketdump_SOURCES = tools/WebSocketDump.cpp \
+ $(shared_sources)
+
wsd_headers = wsd/Admin.hpp \
wsd/AdminModel.hpp \
wsd/Auth.hpp \