summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorHenry Castro <hcastro@collabora.com>2017-06-18 14:19:10 -0400
committerHenry Castro <hcastro@collabora.com>2017-06-18 14:21:33 -0400
commitc24585741d19a9512cf81a6629e8c410ea35de13 (patch)
tree6d36309f0907207bb1880b9f52229f2b21061f93 /Makefile.am
parentCheck for spare space in the right place. (diff)
downloadonline-c24585741d19a9512cf81a6629e8c410ea35de13.tar.gz
online-c24585741d19a9512cf81a6629e8c410ea35de13.zip
fix compilation errors with --disable-ssl option
Change-Id: I777f0ebf054db0a5fd2c64e6d56a222826b40045
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index b1e1c39d1b..992ab68ec1 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -40,6 +40,10 @@ AM_LDFLAGS = -pthread -Wl,-E,-rpath,/snap/loolwsd/current/usr/lib $(ZLIB_LIBS)
if ENABLE_SSL
AM_LDFLAGS += -lssl -lcrypto
+else
+loolwsd_fuzzer_LDADD = -lssl -lcrypto
+loolwsd_LDADD = -lssl -lcrypto
+loolconfig_LDADD = -lssl -lcrypto
endif
loolwsd_fuzzer_CPPFLAGS = -DKIT_IN_PROCESS=1 -DFUZZER=1 -DTDOC=\"$(abs_top_srcdir)/test/data\" $(AM_CPPFLAGS)