summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMiklos Vajna <vmiklos@collabora.co.uk>2017-06-22 09:03:35 +0200
committerMiklos Vajna <vmiklos@collabora.co.uk>2017-06-22 09:03:54 +0200
commitad8584f5d737bc681f363c6612c28d4d3525b836 (patch)
tree45fc0e53f50f9b82bb79e331bf628b89669e3558 /Makefile.am
parentfix js lint error (diff)
downloadonline-ad8584f5d737bc681f363c6612c28d4d3525b836.tar.gz
online-ad8584f5d737bc681f363c6612c28d4d3525b836.zip
tools: initializer for base class XMLConfiguration is redundant, remove it
Also run the clang static analyzer on net/ by excluding test/, and not explicitly listing all non-test directories. Change-Id: Iac203f1cf9161da1c51501de8b0c3cc9dc6e2027
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 992ab68ec1..1ec26be044 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -281,7 +281,7 @@ clean-cache cache-clean:
test -n "@LOOLWSD_CACHEDIR@" && rm -rf "@LOOLWSD_CACHEDIR@"/[0-9a-f]
clang-tidy:
- for i in {common,kit,tools,wsd}/*.cpp; do echo $$i; clang-tidy -header-filter=^$(PWD).* $$i || break; done
+ for i in $(shell git ls-files|grep /.*cpp$$|grep -v test); do echo $$i; clang-tidy -header-filter=^$(PWD).* $$i || break; done
# After building loolforkit, set its capabilities as required. Do it
# already after a plain 'make' to allow for testing without