summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorPranav Kant <pranavk@collabora.co.uk>2017-05-24 14:22:24 +0530
committerPranav Kant <pranavk@collabora.co.uk>2017-05-25 01:18:31 +0530
commit9bd89e89c31c6e0864bcfa5f550fdbf2e1cd9a49 (patch)
tree4f81f80cff66fbd9948cb08a7f85245d63f4c220 /Makefile.am
parentloleaflet: simplify disable about dialog (diff)
downloadonline-9bd89e89c31c6e0864bcfa5f550fdbf2e1cd9a49.tar.gz
online-9bd89e89c31c6e0864bcfa5f550fdbf2e1cd9a49.zip
loolconfig: tool to generate admin password hash with PBKDF2
A normal usage to set the admin password would be like : loolconfig set-admin-password --config-file ./loolwsd.xml Other command line options can also be given, like --pwd-salt-length, --pwd-hash-length, --pwd-iterations. Change-Id: I2a6f8d25e068b53a3f945426f0779c8410b2c8ba
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 73c26140f1..bd94892983 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -2,7 +2,7 @@ SUBDIRS = . test loleaflet
export ENABLE_DEBUG
-bin_PROGRAMS = loolwsd loolforkit loolmap loolmount looltool loolstress
+bin_PROGRAMS = loolwsd loolforkit loolmap loolmount looltool loolstress loolconfig
dist_bin_SCRIPTS = loolwsd-systemplate-setup
@@ -135,6 +135,8 @@ loolstress_SOURCES = tools/Stress.cpp \
common/Log.cpp \
common/Util.cpp
+loolconfig_SOURCES = tools/Config.cpp
+
wsd_headers = wsd/Admin.hpp \
wsd/AdminModel.hpp \
wsd/Auth.hpp \