summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMichael Meeks <michael.meeks@collabora.com>2017-04-28 11:02:06 +0100
committerMichael Meeks <michael.meeks@collabora.com>2017-04-28 14:26:21 +0100
commit7f4f7526674af84660b50b8156e7c3c741d0751c (patch)
tree257f80a69f955782ce1ae8d916e37f3b7647e834 /Makefile.am
parentDistribute the git hash for easier identification. (diff)
downloadonline-7f4f7526674af84660b50b8156e7c3c741d0751c.tar.gz
online-7f4f7526674af84660b50b8156e7c3c741d0751c.zip
Initial seccomp work.
Add a list of unhelpful looking system calls to improve containment. Change-Id: I2e4bf3e0a6a752d427299728663d17120586bb10
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index cfcfd7c36f..622fe55001 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -47,6 +47,7 @@ shared_sources = common/FileUtil.cpp \
common/Log.cpp \
common/Protocol.cpp \
common/Session.cpp \
+ common/Seccomp.cpp \
common/MessageQueue.cpp \
common/SigUtil.cpp \
common/SpookyV2.cpp \
@@ -152,6 +153,7 @@ shared_headers = common/Common.hpp \
common/Log.hpp \
common/LOOLWebSocket.hpp \
common/Protocol.hpp \
+ common/Seccomp.hpp \
common/Session.hpp \
common/Unit.hpp \
common/UnitHTTP.hpp \