summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorAshod Nakashian <ashod.nakashian@collabora.co.uk>2017-04-03 21:05:36 -0400
committerAshod Nakashian <ashnakash@gmail.com>2017-04-04 04:15:53 +0000
commit66a76f644bde3aa21f9de4e095be8c8300cbf021 (patch)
treeab4f62b3b70517a93df8e379667de7d81ab2e826 /Makefile.am
parentloleaflet: add a permanent overlay text selection of the annotation object (diff)
downloadonline-66a76f644bde3aa21f9de4e095be8c8300cbf021.tar.gz
online-66a76f644bde3aa21f9de4e095be8c8300cbf021.zip
wsd: enable logging with valgrind
Change-Id: I411f7de3d5764cd25af211f2dc77bf0e290adbc7 Reviewed-on: https://gerrit.libreoffice.org/36054 Reviewed-by: Ashod Nakashian <ashnakash@gmail.com> Tested-by: Ashod Nakashian <ashnakash@gmail.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am11
1 files changed, 8 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 76f1dc8d1e..a438ff7d82 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -226,27 +226,32 @@ run: all @JAILS_PATH@ @SYSTEMPLATE_PATH@/system_stamp
--o:ssl.cert_file_path="$(abs_top_srcdir)/etc/cert.pem" \
--o:ssl.key_file_path="$(abs_top_srcdir)/etc/key.pem" \
--o:ssl.ca_file_path="$(abs_top_srcdir)/etc/ca-chain.cert.pem" \
- --o:admin_console.username=admin --o:admin_console.password=admin
+ --o:admin_console.username=admin --o:admin_console.password=admin \
+ --o:logging.file[@enable]=false --o:logging.level=trace
run-valgrind: all @JAILS_PATH@ @SYSTEMPLATE_PATH@/system_stamp
@echo "Launching loolwsd under valgrind (but not forkit/loolkit, yet)"
+ @cp $(abs_top_srcdir)/test/data/hello.odt $(abs_top_srcdir)/test/data/hello-world.odt
valgrind --tool=memcheck --trace-children=no -v --read-var-info=yes \
./loolwsd --o:sys_template_path="@SYSTEMPLATE_PATH@" --o:lo_template_path="@LO_PATH@" \
--o:child_root_path="@JAILS_PATH@" --o:storage.filesystem[@allow]=true \
--o:ssl.cert_file_path="$(abs_top_srcdir)/etc/cert.pem" \
--o:ssl.key_file_path="$(abs_top_srcdir)/etc/key.pem" \
--o:ssl.ca_file_path="$(abs_top_srcdir)/etc/ca-chain.cert.pem" \
- --o:admin_console.username=admin --o:admin_console.password=admin
+ --o:admin_console.username=admin --o:admin_console.password=admin \
+ --o:logging.file[@enable]=false --o:logging.level=trace
run-callgrind: all @JAILS_PATH@ @SYSTEMPLATE_PATH@/system_stamp
@echo "Launching loolwsd under valgrind (but not forkit/loolkit, yet)"
+ @cp $(abs_top_srcdir)/test/data/hello.odt $(abs_top_srcdir)/test/data/hello-world.odt
valgrind --tool=callgrind --simulate-cache=yes --dump-instr=yes --num-callers=50 --error-limit=no \
./loolwsd --o:sys_template_path="@SYSTEMPLATE_PATH@" --o:lo_template_path="@LO_PATH@" \
--o:child_root_path="@JAILS_PATH@" --o:storage.filesystem[@allow]=true \
--o:ssl.cert_file_path="$(abs_top_srcdir)/etc/cert.pem" \
--o:ssl.key_file_path="$(abs_top_srcdir)/etc/key.pem" \
--o:ssl.ca_file_path="$(abs_top_srcdir)/etc/ca-chain.cert.pem" \
- --o:admin_console.username=admin --o:admin_console.password=admin
+ --o:admin_console.username=admin --o:admin_console.password=admin \
+ --o:logging.file[@enable]=false --o:logging.level=trace
else
SYSTEM_STAMP =