summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorChristian Glombek <christian.glombek@rwth-aachen.de>2018-02-01 14:49:44 +0100
committerAndras Timar <andras.timar@collabora.com>2018-02-04 22:27:09 +0100
commit51993b8990c8eb0123e860088df09e3ad6436079 (patch)
treef70d4c731d7d50e535fa5cbf6b5269dbe01cac09 /Makefile.am
parentloleaflet: Don't try to translate command names (diff)
downloadonline-51993b8990c8eb0123e860088df09e3ad6436079.tar.gz
online-51993b8990c8eb0123e860088df09e3ad6436079.zip
Adds ENABLE_SETCAP build variable to avoid using env in build system.
Change-Id: Id38d2225238f8b3a48481a08e62cfa7544958cc9 Reviewed-on: https://gerrit.libreoffice.org/49097 Reviewed-by: Thorsten Behrens <Thorsten.Behrens@CIB.de> Reviewed-by: Andras Timar <andras.timar@collabora.com> Tested-by: Andras Timar <andras.timar@collabora.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am14
1 files changed, 7 insertions, 7 deletions
diff --git a/Makefile.am b/Makefile.am
index 2fce7fddab..542f8d5337 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -314,13 +314,13 @@ clang-tidy:
# installing the RPM or Debian package.
all-local: loolforkit @JAILS_PATH@ $(SYSTEM_STAMP)
- @if test "$$BUILDING_FROM_RPMBUILD" != yes; then \
- sudo @SETCAP@ cap_fowner,cap_mknod,cap_sys_chroot=ep loolforkit; \
- sudo @SETCAP@ cap_sys_admin=ep loolmount; \
- echo "Set required capabilities"; \
- else \
- echo "Skipping capability setting"; \
- fi
+if ENABLE_SETCAP
+ sudo @SETCAP@ cap_fowner,cap_mknod,cap_sys_chroot=ep loolforkit
+ sudo @SETCAP@ cap_sys_admin=ep loolmount
+ echo "Set required capabilities"
+else
+ echo "Skipping capability setting"
+endif
# just run the build without any tests
build-nocheck: all-am