summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorJan Holesovsky <kendy@collabora.com>2017-04-05 11:57:28 +0200
committerJan Holesovsky <kendy@collabora.com>2017-04-05 12:03:33 +0200
commit37387518f43f895bde0db877ca4d5fe94c0d28e6 (patch)
treedf75ae3282cda08eec43aa564ddf032e081914ec /Makefile.am
parentThe other isCorrectThread() should be active only in the debug build too. (diff)
downloadonline-37387518f43f895bde0db877ca4d5fe94c0d28e6.tar.gz
online-37387518f43f895bde0db877ca4d5fe94c0d28e6.zip
Suppress assert()'s in the production builds.
Change-Id: I2074ed335b7201337e6519440ff6bed1809be915
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 3f45901eee..c472180560 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -27,6 +27,10 @@ AM_CPPFLAGS = -pthread -DLOOLWSD_DATADIR='"@LOOLWSD_DATADIR@"' \
-DDEBUG_ABSSRCDIR='"@abs_srcdir@"' \
${include_paths}
+if !ENABLE_DEBUG
+AM_CPPFLAGS += -DNDEBUG
+endif
+
AM_LDFLAGS = -pthread -Wl,-E,-rpath,/snap/loolwsd/current/usr/lib $(ZLIB_LIBS)
if ENABLE_SSL