summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorJan Holesovsky <kendy@collabora.com>2018-01-26 20:27:51 +0100
committerJan Holesovsky <kendy@collabora.com>2018-01-26 20:40:17 +0100
commit0039f3c041b0d687c0495741d53eca800ee8f894 (patch)
tree221715225e8e6a1a2bc29501e241d76724c53a61 /Makefile.am
parentkit: start spamming the logs when linking/copying is slowww (diff)
downloadonline-0039f3c041b0d687c0495741d53eca800ee8f894.tar.gz
online-0039f3c041b0d687c0495741d53eca800ee8f894.zip
Add run-strace target for easy stracing.
Change-Id: I554cfa3965784803430a4cc2c12e61002e2445cd
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am15
1 files changed, 15 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index d0e2ae2daf..2fce7fddab 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -279,6 +279,21 @@ run-callgrind: all @JAILS_PATH@ @SYSTEMPLATE_PATH@/system_stamp
--o:ssl.ca_file_path="$(abs_top_srcdir)/etc/ca-chain.cert.pem" \
--o:admin_console.username=admin --o:admin_console.password=admin \
--o:logging.file[@enable]=false --o:logging.level=error
+
+run-strace: all @JAILS_PATH@ @SYSTEMPLATE_PATH@/system_stamp
+ @echo "Launching loolwsd under strace"
+ @fc-cache "@LO_PATH@"/share/fonts/truetype
+ @cp $(abs_top_srcdir)/test/data/hello.odt $(abs_top_srcdir)/test/data/hello-world.odt
+ strace -o strace.log -f -tt -s 256 \
+ ./loolwsd --nocaps \
+ --o:sys_template_path="@SYSTEMPLATE_PATH@" --o:lo_template_path="@LO_PATH@" \
+ --o:child_root_path="@JAILS_PATH@" --o:storage.filesystem[@allow]=true \
+ --o:ssl.cert_file_path="$(abs_top_srcdir)/etc/cert.pem" \
+ --o:ssl.key_file_path="$(abs_top_srcdir)/etc/key.pem" \
+ --o:ssl.ca_file_path="$(abs_top_srcdir)/etc/ca-chain.cert.pem" \
+ --o:admin_console.username=admin --o:admin_console.password=admin \
+ --o:logging.file[@enable]=false --o:logging.level=error
+
else
SYSTEM_STAMP =