summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorTor Lillqvist <tml@collabora.com>2021-06-01 13:21:09 +0300
committerTor Lillqvist <tml@iki.fi>2021-06-02 09:04:21 +0300
commit8cef48a0fa060b51952cc65019b7e094e53802d4 (patch)
tree04fd526322ea8a3903d3fbcda3d5cd6fbcde6d8e /Makefile.am
parentwsd: revisit log messages ClientSession.cpp (diff)
downloadonline-8cef48a0fa060b51952cc65019b7e094e53802d4.tar.gz
online-8cef48a0fa060b51952cc65019b7e094e53802d4.zip
Introduce a generic TraceEvent class and instant events here, too
Modelled on how it is done in core. ProfileZone is derived from NamedEvent which is derived from TraceEvent. Here we don't keep any separate ProfileZone.hpp, though. This was needed to introduce generation of "instant" events here, too. Signed-off-by: Tor Lillqvist <tml@collabora.com> Change-Id: I6583134e96001641c50339deb4197fca6ab7d5d5
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index c96336a62c..a3578ddc2a 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -97,7 +97,7 @@ shared_sources = common/FileUtil.cpp \
common/Seccomp.cpp \
common/MessageQueue.cpp \
common/MobileApp.cpp \
- common/ProfileZone.cpp \
+ common/TraceEvent.cpp \
common/SigUtil.cpp \
common/SpookyV2.cpp \
common/Unit.cpp \
@@ -276,7 +276,7 @@ shared_headers = common/Common.hpp \
common/Message.hpp \
common/MobileApp.hpp \
common/Png.hpp \
- common/ProfileZone.hpp \
+ common/TraceEvent.hpp \
common/Rectangle.hpp \
common/RenderTiles.hpp \
common/SigUtil.hpp \