summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorMichael Meeks <michael.meeks@novell.com>2011-09-09 16:40:36 +0100
committerMichael Meeks <michael.meeks@novell.com>2011-09-10 16:52:06 +0200
commitf2cc639131e62187a51b39555a24efc47b87fb13 (patch)
treee16c52092424de4184f0cd84f30ce0f48b279866 /configure.in
parentRevert partly cppcheck cleaning (diff)
downloadcore-f2cc639131e62187a51b39555a24efc47b87fb13.tar.gz
core-f2cc639131e62187a51b39555a24efc47b87fb13.zip
Add detection of stale / slow makes (for Windows) and warn about them.
Diffstat (limited to 'configure.in')
-rwxr-xr-xconfigure.in8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index fad509a1f712..9de186e093f4 100755
--- a/configure.in
+++ b/configure.in
@@ -2541,6 +2541,14 @@ else
fi
AC_SUBST(GNUMAKE)
+_make_ver_check=`$GNUMAKE --version | grep LibreOffice`;
+STALE_MAKE=
+make_warning=
+if test "z$_make_ver_check" = "z"; then
+ STALE_MAKE=TRUE
+fi
+AC_SUBST(STALE_MAKE)
+
dnl ===================================================================
dnl Test the Solaris compiler version
dnl ===================================================================