summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorMichael Stahl <mst@openoffice.org>2011-10-10 18:10:12 +0200
committerMichael Stahl <mst@openoffice.org>2011-10-11 17:56:59 +0200
commite0c72547ce57c25db61ec3da6c2f2f2792348c7d (patch)
treedd3adb4f7d88081a91924938ff7cba6f449d775d /configure.in
parentmove #endif to better place (diff)
downloadcore-e0c72547ce57c25db61ec3da6c2f2f2792348c7d.tar.gz
core-e0c72547ce57c25db61ec3da6c2f2f2792348c7d.zip
enable libstdc++ debug mode with --enable-dbgutil
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in16
1 files changed, 16 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index a5569dd0445e..c613ffb1eaa4 100644
--- a/configure.in
+++ b/configure.in
@@ -2303,6 +2303,22 @@ if test -n "$enable_dbgutil" && test "$enable_dbgutil" != "no"; then
PROEXT=""
PRODUCT=""
AC_MSG_RESULT([yes])
+ # cppunit and graphite expose STL in public headers
+ if test "$with_system_cppunit" = "yes"; then
+ AC_MSG_ERROR([--with-system-cppunit conflicts with DBG_UTIL build])
+ else
+ with_system_cppunit=no
+ fi
+ if test "$with_system_graphite" = "yes"; then
+ AC_MSG_ERROR([--with-system-graphite conflicts with DBG_UTIL build])
+ else
+ with_system_graphite=no
+ fi
+ if test "$with_system_mysql_cppconn" = "yes"; then
+ AC_MSG_ERROR([--with-system-mysql-cppconn conflicts with DBG_UTIL build])
+ else
+ with_system_mysql_cppconn=no
+ fi
if test $_os = WINNT -a \
\( "$enable_mozilla" = yes -o \
"$enable_nss_module" = yes -o \