summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorNorbert Thiebaud <nthiebaud@gmail.com>2011-09-10 18:35:43 -0500
committerNorbert Thiebaud <nthiebaud@gmail.com>2011-09-10 18:35:43 -0500
commitab32bfd3ce3b21a7debfbdc41b5653dabf9b1389 (patch)
treeed1d641035bd0168eaf67465f8036d2d10b2c1d9 /configure.in
parentlink gdb python helpers across into the install as well (diff)
downloadcore-ab32bfd3ce3b21a7debfbdc41b5653dabf9b1389.tar.gz
core-ab32bfd3ce3b21a7debfbdc41b5653dabf9b1389.zip
try to use our 'own' make if installed in /opt/lo/bin/make
if GNUMAKE is undefined and /opt/lo/bin/make is an executable then define GNUMAKE as /opt/lo/bin/make
Diffstat (limited to 'configure.in')
-rwxr-xr-xconfigure.in8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 9de186e093f4..4fb2156a0c91 100755
--- a/configure.in
+++ b/configure.in
@@ -2515,6 +2515,14 @@ dnl ===================================================================
dnl Search all the common names for GNU make
dnl ===================================================================
AC_MSG_CHECKING([for GNU make])
+
+# try to use our own make if it is available and GNUMAKE was not already defined
+if test -z "$GNUMAKE"; then
+ if test -x "/opt/lo/bin/make"; then
+ GNUMAKE="/opt/lo/bin/make"
+ fi
+fi
+
for a in "$MAKE" $GNUMAKE make gmake gnumake; do
$a --version 2> /dev/null | grep GNU 2>&1 > /dev/null
if test $? -eq 0; then