summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorTomas Chvatal <tchvatal@suse.cz>2011-09-18 08:41:21 +0200
committerTomas Chvatal <tchvatal@suse.cz>2011-09-18 11:04:29 +0200
commita7d38f57cc0bc8d8b941f17e1fd5b8f9eb3a87c9 (patch)
tree613aa00a7cdce335dc79b3796210173fc139e3d0 /configure.in
parentfix cross-compilation failure after gbuildization of desktop (diff)
downloadcore-a7d38f57cc0bc8d8b941f17e1fd5b8f9eb3a87c9.tar.gz
core-a7d38f57cc0bc8d8b941f17e1fd5b8f9eb3a87c9.zip
Revert "Remove once again the INSTALLDIR feature"
This reverts commit bf0ea5c4eefa122febaaa5e6da8ecf4b1869f991. Those variables are used in bin/distro-install-*. Unable to find any issue with both distro-install and dev-install so reverting. If something really does break it needs fixing. Reverting this is not an option.
Diffstat (limited to 'configure.in')
-rwxr-xr-xconfigure.in13
1 files changed, 13 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index edc956ae7cf5..4d26a474b9f1 100755
--- a/configure.in
+++ b/configure.in
@@ -9168,6 +9168,14 @@ PRODUCTNAME=AC_PACKAGE_NAME
AC_MSG_RESULT([$PRODUCTNAME])
AC_SUBST(PRODUCTNAME)
+INSTALLDIRNAME=`echo AC_PACKAGE_NAME | tr [[:upper:]] [[:lower:]]`
+AC_MSG_CHECKING([for install dirname])
+if test -n "$with_install_dirname" -a "$with_install_dirname" != "no" -a "$with_install_dirname" != "yes" ; then
+ INSTALLDIRNAME="$with_install_dirname"
+fi
+AC_MSG_RESULT([$INSTALLDIRNAME])
+AC_SUBST(INSTALLDIRNAME)
+
AC_MSG_CHECKING([for prefix])
PREFIXDIR="$prefix"
AC_MSG_RESULT([$PREFIXDIR])
@@ -9193,6 +9201,11 @@ DOCDIR=[$(eval echo $(eval echo $docdir))]
AC_MSG_RESULT([$DOCDIR])
AC_SUBST(DOCDIR)
+AC_MSG_CHECKING([for install dir])
+INSTALLDIR="$LIBDIR/$INSTALLDIRNAME"
+AC_MSG_RESULT([$INSTALLDIR])
+AC_SUBST(INSTALLDIR)
+
AC_MSG_CHECKING([whether to statically link to Gtk])
if test -n "$enable_static_gtk" && test "$enable_static_gtk" != "no"; then
ENABLE_STATIC_GTK="TRUE"