summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorJan Holesovsky <kendy@suse.cz>2011-08-19 15:01:17 +0200
committerJan Holesovsky <kendy@suse.cz>2011-08-19 15:36:18 +0200
commit81ca6d858b2e50ded7a4f713cc134a13c1fbf886 (patch)
treedfc4acfe74d9c74e47a5bad864d2b7474768fefe /configure.in
parentdeliver also unotools.hxx (diff)
downloadcore-81ca6d858b2e50ded7a4f713cc134a13c1fbf886.tar.gz
core-81ca6d858b2e50ded7a4f713cc134a13c1fbf886.zip
Allow parallel build of the the cross build toolset.
Plus various minor build tweaks.
Diffstat (limited to 'configure.in')
-rwxr-xr-xconfigure.in12
1 files changed, 11 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 782d4ccd0821..cbd835c7e2eb 100755
--- a/configure.in
+++ b/configure.in
@@ -1538,6 +1538,12 @@ cygwin*|interix*|mingw32*)
mingw32*)
WITH_MINGW=yes
+ if test -z "$CC" ; then
+ CC="$host_cpu-$host_vendor-$host_os-gcc"
+ fi
+ if test -z "$CXX" ; then
+ CXX="$host_cpu-$host_vendor-$host_os-g++"
+ fi
;;
esac
;;
@@ -4696,7 +4702,11 @@ if test $enable_python != no; then
BUILD_TYPE="$BUILD_TYPE PYUNO"
fi
-if test "$cross_compiling" != yes; then
+if test "$cross_compiling" = yes; then
+ if test $enable_python = auto; then
+ enable_python=system
+ fi
+else
if test $enable_python = system; then
dnl This causes an error if no Python found
AM_PATH_PYTHON([2.6])