summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorTomas Chvatal <tchvatal@suse.cz>2011-09-17 12:46:21 +0200
committerTomas Chvatal <tchvatal@suse.cz>2011-09-17 12:46:21 +0200
commit7b502808dba8a4790a94182bf9835ba702f6f81b (patch)
tree302adb1120c95f9937b597bc01aa8770e8532ae6 /configure.in
parentForce JVM into interpreted mode when running under Valgrind, to avoid false e... (diff)
downloadcore-7b502808dba8a4790a94182bf9835ba702f6f81b.tar.gz
core-7b502808dba8a4790a94182bf9835ba702f6f81b.zip
Make --with-theme actually work.
Diffstat (limited to 'configure.in')
-rwxr-xr-xconfigure.in11
1 files changed, 5 insertions, 6 deletions
diff --git a/configure.in b/configure.in
index 6fd2d00e7f20..a99ddb032f74 100755
--- a/configure.in
+++ b/configure.in
@@ -7747,15 +7747,14 @@ dnl Test which themes to include
dnl ===================================================================
AC_MSG_CHECKING([which themes to include])
# if none given, use all available themes
-if test "z$enable_theme" = "z" -o "z$enable_theme" = "zyes"; then
- enable_theme="default crystal hicontrast oxygen tango"
-fi
+AS_IF([test "x$with_theme" = "x" -o "x$with_theme" = "xyes"], [
+ with_theme="default crystal hicontrast oxygen tango"
+])
WITH_THEMES=""
-for theme in $enable_theme
-do
+for theme in $with_theme; do
WITH_THEMES="$WITH_THEMES $theme"
- SCPDEFS="$SCPDEFS -DTHEME_`echo $theme|tr '[a-z]' '[A-Z]'`"
+ SCPDEFS="$SCPDEFS -DTHEME_`echo $theme|tr '[:lower:]' '[:upper:]'`"
done
AC_MSG_RESULT([$WITH_THEMES])
AC_SUBST(WITH_THEMES)