summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorFrançois Tigeot <ftigeot@wolfpond.org>2011-08-21 20:36:09 +0200
committerFrançois Tigeot <ftigeot@wolfpond.org>2011-08-22 21:11:18 +0200
commit7b4825af2c345881c0a7d87b6e0a450fe74fd8ab (patch)
treebd5bcec789429651ab84343fbb34a7a093f618dd /configure.in
parentDrop OS/2 lines (diff)
downloadcore-7b4825af2c345881c0a7d87b6e0a450fe74fd8ab.tar.gz
core-7b4825af2c345881c0a7d87b6e0a450fe74fd8ab.zip
Enable CUPS unconditionally
It doesn't make sense to try to use anything else to print on *nix systems these days
Diffstat (limited to 'configure.in')
-rwxr-xr-xconfigure.in30
1 files changed, 5 insertions, 25 deletions
diff --git a/configure.in b/configure.in
index 87522f7ac525..e362edb41219 100755
--- a/configure.in
+++ b/configure.in
@@ -180,10 +180,6 @@ AC_ARG_ENABLE(evolution2,
[Allows the built-in evolution 2 addressbook connectivity build to be
enabled.]))
-AC_ARG_ENABLE(cups,
- AS_HELP_STRING([--disable-cups],
- [Disable cups support in the psprint project.]))
-
AC_ARG_ENABLE(directx,
AS_HELP_STRING([--disable-directx],
[Remove DirectX implementation for the new XCanvas interface.
@@ -1461,7 +1457,6 @@ dnl These values may be checked and reset later.
dnl ===================================================================
#defaults unless the os test overrides this:
test_randr=yes
-test_cups=yes
test_fontconfig=yes
case "$host_os" in
@@ -1511,7 +1506,6 @@ linux-gnu*|k*bsd*-gnu*)
gnu)
test_randr=no
- test_cups=no
_os=GNU
;;
@@ -1532,7 +1526,6 @@ cygwin*|interix*|mingw32*)
# is "mingw32" (because in that case it is the MinGW
# tool-chain that is used).
- test_cups=no
test_randr=no
test_freetype=no
test_fontconfig=no
@@ -1608,7 +1601,6 @@ freebsd*)
;;
aix*)
- test_cups=no
test_randr=no
test_freetype=yes
PTHREAD_LIBS=-pthread
@@ -1636,7 +1628,6 @@ dragonfly*)
androideabi*)
build_gstreamer=no
- test_cups=no
test_fontconfig=no
test_freetype=no
test_gtk=no
@@ -2279,20 +2270,12 @@ AC_SUBST(DISABLE_STRIP)
dnl check for cups support
dnl ===================================================================
-AC_MSG_CHECKING([whether to enable native cups support])
-if test "$test_cups" = "yes" -a "z$enable_cups" != "zno"; then
- ENABLE_CUPS="TRUE"
- AC_MSG_RESULT([yes])
- AC_CHECK_LIB(cups, cupsPrintFiles)
- AC_CHECK_HEADER(cups/cups.h, AC_DEFINE(HAVE_CUPS_H))
- if test "$ac_cv_lib_cups_cupsPrintFiles" != "yes" -a "$ac_cv_header_cups_cups_h" != "yes"; then
- AC_MSG_ERROR([Could not find CUPS. Install libcupsys2-dev or cups???-devel.])
- fi
-else
- ENABLE_CUPS=""
- AC_MSG_RESULT([no])
+AC_MSG_CHECKING([whether cups support is present])
+AC_CHECK_LIB(cups, cupsPrintFiles)
+AC_CHECK_HEADER(cups/cups.h, AC_DEFINE(HAVE_CUPS_H))
+if test "$ac_cv_lib_cups_cupsPrintFiles" != "yes" -a "$ac_cv_header_cups_cups_h" != "yes"; then
+ AC_MSG_ERROR([Could not find CUPS. Install libcupsys2-dev or cups???-devel.])
fi
-AC_SUBST(ENABLE_CUPS)
# check for fontconfig support
@@ -5939,9 +5922,6 @@ if test "$_os" = "Darwin"; then
x_libraries="no_x_libraries"
dnl disable some things used on other Unix versions but not on the aqua build
enable_gtk=no
- enable_cups=no
- ENABLE_CUPS=""
- AC_SUBST(ENABLE_CUPS)
else
AC_MSG_ERROR([No AppKit.framewrok found])
fi