summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorNoel Grandin <noelgrandin@gmail.com>2012-08-28 07:00:18 +0200
committerDavid Tardon <dtardon@redhat.com>2012-08-28 07:00:18 +0200
commit3ee97489ea49b339c4a7578afd85f85f77dd0f68 (patch)
tree23ea6a66dbb9206b362adfaa3641819e0a18c65e /configure.in
parentresolved fdo#51926 handle .xlsm link to external sheet with space (diff)
downloadcore-3ee97489ea49b339c4a7578afd85f85f77dd0f68.tar.gz
core-3ee97489ea49b339c4a7578afd85f85f77dd0f68.zip
allow separate setting of parallelism for subseq. tests
Change-Id: I5a5444e8ee95b0fd95a97c31c94ab0f9c3935abb
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in17
1 files changed, 17 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index db2850415d09..51c1ff22292e 100644
--- a/configure.in
+++ b/configure.in
@@ -2068,6 +2068,12 @@ AC_ARG_WITH(max-jobs,
Defaults to 1, unless you configure --enable-icecream - then to 10.]),
,)
+AC_ARG_WITH(check-jobs,
+ AS_HELP_STRING([--with-check-jobs],
+ [Maximum number of jobs that will be issued at the same time during 'make subsequenttest'.
+ Default value is the same as 'max-jobs'. Useful because the subsequent tests are very lighweight.]),
+,)
+
dnl ===================================================================
dnl MacOSX build and runtime environment options
dnl ===================================================================
@@ -12166,6 +12172,17 @@ AC_SUBST(GMAKE_PARALLELISM)
AC_SUBST(GMAKE_MODULE_PARALLELISM)
dnl ===================================================================
+dnl Number of parallel jobs to be executed during subsequenttest
+dnl ===================================================================
+AC_MSG_CHECKING([for maximum no. of jobs during subsequenttest])
+CHECK_PARALLELISM=$GMAKE_PARALLELISM
+if test "$with_check_jobs" != ""; then
+ CHECK_PARALLELISM="$with_check_jobs"
+fi
+AC_MSG_RESULT([$CHECK_PARALLELISM])
+AC_SUBST(CHECK_PARALLELISM)
+
+dnl ===================================================================
dnl Setting up the environment.
dnl ===================================================================
echo "setting up the build environment variables..."