summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorFrançois Tigeot <ftigeot@wolfpond.org>2011-08-22 23:28:21 +0200
committerFrançois Tigeot <ftigeot@wolfpond.org>2011-08-22 23:29:32 +0200
commit107d717941f997d1166ff6a5e8f869574a88c76d (patch)
treec2a9051478c8ad27c8b19aea5a401320ab3a004b /configure.in
parentcheck we have the environment sourced, and fail helpfully if not (diff)
downloadcore-107d717941f997d1166ff6a5e8f869574a88c76d.tar.gz
core-107d717941f997d1166ff6a5e8f869574a88c76d.zip
Do not check for cups presence on Windows and Android systems
Diffstat (limited to 'configure.in')
-rwxr-xr-xconfigure.in13
1 files changed, 9 insertions, 4 deletions
diff --git a/configure.in b/configure.in
index e362edb41219..6a299e357b9b 100755
--- a/configure.in
+++ b/configure.in
@@ -1457,6 +1457,7 @@ dnl These values may be checked and reset later.
dnl ===================================================================
#defaults unless the os test overrides this:
test_randr=yes
+test_cups=yes
test_fontconfig=yes
case "$host_os" in
@@ -1526,6 +1527,7 @@ cygwin*|interix*|mingw32*)
# is "mingw32" (because in that case it is the MinGW
# tool-chain that is used).
+ test_cups=no
test_randr=no
test_freetype=no
test_fontconfig=no
@@ -1628,6 +1630,7 @@ dragonfly*)
androideabi*)
build_gstreamer=no
+ test_cups=no
test_fontconfig=no
test_freetype=no
test_gtk=no
@@ -2271,10 +2274,12 @@ AC_SUBST(DISABLE_STRIP)
dnl check for cups support
dnl ===================================================================
AC_MSG_CHECKING([whether cups support is present])
-AC_CHECK_LIB(cups, cupsPrintFiles)
-AC_CHECK_HEADER(cups/cups.h, AC_DEFINE(HAVE_CUPS_H))
-if test "$ac_cv_lib_cups_cupsPrintFiles" != "yes" -a "$ac_cv_header_cups_cups_h" != "yes"; then
- AC_MSG_ERROR([Could not find CUPS. Install libcupsys2-dev or cups???-devel.])
+if test "$test_cups" = "yes"; then
+ AC_CHECK_LIB(cups, cupsPrintFiles)
+ AC_CHECK_HEADER(cups/cups.h, AC_DEFINE(HAVE_CUPS_H))
+ if test "$ac_cv_lib_cups_cupsPrintFiles" != "yes" -a "$ac_cv_header_cups_cups_h" != "yes"; then
+ AC_MSG_ERROR([Could not find CUPS. Install libcupsys2-dev or cups???-devel.])
+ fi
fi