summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorChristian Lohmaier <lohmaier+LibreOffice@googlemail.com>2013-03-19 17:39:58 +0100
committerFridrich Strba <fridrich@documentfoundation.org>2013-03-20 06:37:19 +0000
commitf44f1719efafd811bb604f7fcc3534d5ec344ad0 (patch)
treeeb71455da4d2a53f6c4cac7936dadb04a231ee71 /configure.ac
parent'size_t' is not the same as 'unsigned long' (diff)
downloadcore-f44f1719efafd811bb604f7fcc3534d5ec344ad0.tar.gz
core-f44f1719efafd811bb604f7fcc3534d5ec344ad0.zip
lowering baseline for python used during building
builds fine when using system python for building on Mac OSX 10.5 (comes with python 2.5 only). Note that python 2.5 is not enough for pyuno/python scripting at runtime, so for that internal python is built nevertheless. Change-Id: I51a4450cad1e09aecd12f192db1fb797313cf322 Reviewed-on: https://gerrit.libreoffice.org/2862 Tested-by: Fridrich Strba <fridrich@documentfoundation.org> Reviewed-by: Fridrich Strba <fridrich@documentfoundation.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 3 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 1492d72160ab..9627162ee985 100644
--- a/configure.ac
+++ b/configure.ac
@@ -7260,13 +7260,14 @@ AC_SUBST([MINGW_LIBXML_DLL])
AC_SUBST([MINGW_ZLIB_DLL])
# =====================================================================
-# Checking for a Python interpreter with version >= 2.6 needed to build LO.
+# Checking for a Python interpreter with version >= 2.5 needed to build LO.
+# runtime requires Python 3 compatible version (>= 2.6)
# Optionally user can pass an option to configure, i. e.
# ./configure PYTHON=/usr/bin/python
# =====================================================================
if test "$build_os" != "cygwin"; then
# This allows a lack of system python with no error, we use internal one in that case.
- AM_PATH_PYTHON([2.6],, [:])
+ AM_PATH_PYTHON([2.5],, [:])
# Clean PYTHON_VERSION checked below if cross-compiling
PYTHON_VERSION=""
if test "$PYTHON" != ":"; then