summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorThorsten Behrens <thorsten.behrens@allotropia.de>2021-11-12 00:34:12 +0100
committerThorsten Behrens <thorsten.behrens@allotropia.de>2021-11-13 16:39:40 +0100
commita323857126dd420f73492a82f31bb7c8d5400ffb (patch)
tree3bf4d4638d87db0028217768ae3fd0bd908255e2 /configure.ac
parentrtl::Static->thread-safe static (diff)
downloadcore-a323857126dd420f73492a82f31bb7c8d5400ffb.tar.gz
core-a323857126dd420f73492a82f31bb7c8d5400ffb.zip
No auto-usage of [s]ccache on Windows for PCH builds
Since that's a pessimisation. Any manual override (--enable-ccache, or --disable-pch) will again make configure auto-enable [s]ccache if binaries are found. Change-Id: I4c0773300c792ebb1807d092d3622d90dfac7d5f Reviewed-on: https://gerrit.libreoffice.org/c/core/+/125073 Tested-by: Jenkins Reviewed-by: Thorsten Behrens <thorsten.behrens@allotropia.de>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 23c2beaceefd..2f1764ac09cc 100644
--- a/configure.ac
+++ b/configure.ac
@@ -5857,6 +5857,10 @@ if test -z "$enable_pch"; then
if test "$_os" = "WINNT"; then
# Enabled by default on Windows.
enable_pch=yes
+ # never use [s]ccache on auto-enabled PCH builds, except if requested explicitely
+ if test -z "$enable_ccache"; then
+ CCACHE=""
+ fi
else
enable_pch=no
fi