summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorLuboš Luňák <l.lunak@centrum.cz>2021-09-20 00:26:29 +0000
committerLuboš Luňák <l.lunak@collabora.com>2021-11-16 13:00:02 +0100
commita0f35cd270fa486deb75e1c2c0516d55723cd04a (patch)
treec167d1132d7f35756ccca073bcef4193fee7a34e /configure.ac
parentmake Skia the default now on Mac too (again) (diff)
downloadcore-a0f35cd270fa486deb75e1c2c0516d55723cd04a.tar.gz
core-a0f35cd270fa486deb75e1c2c0516d55723cd04a.zip
hard-require Clang for Skia also on Mac
Since Skia is now the default on Mac too. Clang on Mac should be the given, but check for consistency. Change-Id: I490d5434374d98b1d7a219c2bca48747e31eecac Reviewed-on: https://gerrit.libreoffice.org/c/core/+/122337 Tested-by: Jenkins Reviewed-by: Luboš Luňák <l.lunak@collabora.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index f0a4b641edab..4ef19213c15d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -12048,10 +12048,10 @@ if test "$ENABLE_SKIA" = TRUE -a "$COM_IS_CLANG" != TRUE; then
fi
fi
if test -z "$LO_CLANG_CC" -o -z "$LO_CLANG_CXX"; then
- # Skia is the default on Windows, so hard-require Clang.
+ # Skia is the default on Windows and Mac, so hard-require Clang.
# Elsewhere it's used just by the 'gen' VCL backend which is rarely used.
- if test "$_os" = "WINNT"; then
- AC_MSG_ERROR([Clang compiler not found. The Skia library needs to be built using Clang.])
+ if test "$_os" = "WINNT" -o "$_os" = "Darwin"; then
+ AC_MSG_ERROR([Clang compiler not found. The Skia library needs to be built using Clang, or use --disable-skia.])
else
AC_MSG_WARN([Clang compiler not found.])
fi