summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorLuboš Luňák <l.lunak@centrum.cz>2021-11-02 18:28:53 +0000
committerLuboš Luňák <l.lunak@collabora.com>2021-11-03 07:27:21 +0100
commit9b9a8f47894760e7a95ed276feeef00d3b1c94d1 (patch)
treed9304e87909718eab1b4a07061314204900b3637 /configure.ac
parentFix typos (diff)
downloadcore-9b9a8f47894760e7a95ed276feeef00d3b1c94d1.tar.gz
core-9b9a8f47894760e7a95ed276feeef00d3b1c94d1.zip
fix gcc-wrapper for ccache.exe
This reverts a part of 18cc01b63996f81b284e3bc827d1be7f3da8983a . Change-Id: Ib7abbc41eeb6abd573f540ae2d0d2822e68b9abb Reviewed-on: https://gerrit.libreoffice.org/c/core/+/124613 Tested-by: Jenkins Reviewed-by: Luboš Luňák <l.lunak@collabora.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 0 insertions, 8 deletions
diff --git a/configure.ac b/configure.ac
index 2c7ed9fb3aec..78dc6c8deae6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -4318,7 +4318,6 @@ AC_SUBST(SHOWINCLUDES_PREFIX)
#
# prefix C with ccache if needed
#
-UNCACHED_CC="$CC"
if test "$CCACHE" != ""; then
AC_MSG_CHECKING([whether $CC_BASE is already ccached])
@@ -6792,7 +6791,6 @@ AC_SUBST(BOOST_CXXFLAGS)
#
# prefx CXX with ccache if needed
#
-UNCACHED_CXX="$CXX"
if test "$CCACHE" != ""; then
AC_MSG_CHECKING([whether $CXX_BASE is already ccached])
AC_LANG_PUSH([C++])
@@ -12360,8 +12358,6 @@ fi
#
# prefix LO_CLANG_CC/LO_CLANG_CXX with ccache if needed
#
-UNCACHED_CLANG_CC="$LO_CLANG_CC"
-UNCACHED_CLANG_CXX="$LO_CLANG_CXX"
if test "$CCACHE" != "" -a -n "$LO_CLANG_CC" -a -n "$LO_CLANG_CXX"; then
AC_MSG_CHECKING([whether $LO_CLANG_CC is already ccached])
AC_LANG_PUSH([C])
@@ -12402,12 +12398,8 @@ if test "$CCACHE" != "" -a -n "$LO_CLANG_CC" -a -n "$LO_CLANG_CXX"; then
AC_LANG_POP([C++])
fi
-AC_SUBST(UNCACHED_CC)
-AC_SUBST(UNCACHED_CXX)
AC_SUBST(LO_CLANG_CC)
AC_SUBST(LO_CLANG_CXX)
-AC_SUBST(UNCACHED_CLANG_CC)
-AC_SUBST(UNCACHED_CLANG_CXX)
AC_SUBST(LO_CLANG_CXXFLAGS_INTRINSICS_SSE2)
AC_SUBST(LO_CLANG_CXXFLAGS_INTRINSICS_SSSE3)
AC_SUBST(LO_CLANG_CXXFLAGS_INTRINSICS_SSE41)