summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorChristian Lohmaier <lohmaier+LibreOffice@googlemail.com>2013-03-17 19:45:26 +0100
committerFridrich Strba <fridrich@documentfoundation.org>2013-03-18 06:55:02 +0000
commit96ad8c2ac54993d7d0e9c6bede7e4aa8f10f9ff1 (patch)
tree815453e9c623113d6ff20b3f07af58b7485cf217 /configure.ac
parentFix fdo#37464 - Cell Border works backwards on Right-to-Left sheet (diff)
downloadcore-96ad8c2ac54993d7d0e9c6bede7e4aa8f10f9ff1.tar.gz
core-96ad8c2ac54993d7d0e9c6bede7e4aa8f10f9ff1.zip
allow openssl in the check-for-broken-make check als sha1sum variant
Mac OS X 10.5 doesn't come with a dedicated sha1sum, but has make 3.81. Allow openssl as alternative for the makefile, after all it isn't sha1 that matters. (also XCode's make is not affected by that specific bug) Change-Id: Id212fca588980f7e151120cdfe281f7b5d8ac5a4 Reviewed-on: https://gerrit.libreoffice.org/2804 Reviewed-by: Fridrich Strba <fridrich@documentfoundation.org> Tested-by: Fridrich Strba <fridrich@documentfoundation.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 3 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 00a47f7f0946..95f548ac6f2f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -4435,9 +4435,11 @@ elif test "$_make_longver" -ge "038100"; then
dnl ===================================================================
dnl Search all the common names for sha1sum
dnl ===================================================================
- AC_PATH_PROGS(SHA1SUM, sha1sum sha1 shasum)
+ AC_CHECK_PROGS(SHA1SUM, sha1sum sha1 shasum openssl)
if test -z "$SHA1SUM"; then
AC_MSG_ERROR([install the approproate SHA-1 checksumming program for this OS])
+ elif test "$SHA1SUM" = "openssl"; then
+ SHA1SUM="openssl sha1"
fi
AC_MSG_CHECKING([for GNU make bug 20033])
TESTGMAKEBUG20033=`mktemp -d tmp.XXXXXX`