summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMichael Stahl <mstahl@redhat.com>2014-08-08 14:58:08 +0200
committerMichael Stahl <mstahl@redhat.com>2014-08-14 18:55:17 +0200
commit8bd6bf93b7711a7ac7c5cbd7c3bb980481570ebd (patch)
tree6b81e0fa2b4bc33c525231969558e5bacddb93be /configure.ac
parentfdo#75757: remove inheritance to std::vector (diff)
downloadcore-8bd6bf93b7711a7ac7c5cbd7c3bb980481570ebd.tar.gz
core-8bd6bf93b7711a7ac7c5cbd7c3bb980481570ebd.zip
fdo#82430: configure: MSVC build: avoid using SSE2 instructions
MSVC 2012 for x86 defaults to -arch:SSE2; binaries do not run on any AMD 32-bit CPU, neither on Intel Pentium III. http://msdn.microsoft.com/en-us/library/vstudio/7t5yh4fd%28v=vs.110%29.aspx Change-Id: Ie8253137db2699f2a7fa69c4ac4e7ded90931e3e
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index e20f112953c8..89d80e7e9233 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3773,6 +3773,9 @@ if test "$_os" = "WINNT"; then
COMPATH=`echo $VC_PRODUCT_DIR`
fi
fi
+ if test "$BITNESS_OVERRIDE" = ""; then
+ CC="$CC -arch:SSE" # MSVC 2012 default for x86 is -arch:SSE2
+ fi
export INCLUDE=`cygpath -d "$COMPATH/Include"`
PathFormat "$COMPATH"